Derivative Images is not working on localhost


#1

I installed latest version of Omeka Classic on localhost, and set the imagemagick path as well, but the system still can not generate derivative images automatically.

I also installed the derivative images plugin. When I try to create derivative images, I get an error as “The configured PHP path () is invalid.”

In config.ini, I tried to type

background.php.path = “”

but nothing changes.

I also tried to type "background.php.path = ""C:\wamp\bin\php\php5.6.25; but nothing changed.

Without using derivative images, I cannot do anything. Can you help me?

exception 'RuntimeException' with message 'The configured PHP path () is invalid.' in C:\wamp\sanalsunucu\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php:114
Stack trace:
#0 C:\wamp\sanalsunucu\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php(93): Omeka_Job_Process_Dispatcher::_checkCliPath('')
#1 C:\wamp\sanalsunucu\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php(28): Omeka_Job_Process_Dispatcher::getPHPCliPath()
#2 C:\wamp\sanalsunucu\omeka\application\libraries\Omeka\Job\Dispatcher\Adapter\BackgroundProcess.php(31): Omeka_Job_Process_Dispatcher::startProcess('Omeka_Job_Proce...', Object(User), Array)
#3 C:\wamp\sanalsunucu\omeka\application\libraries\Omeka\Job\Dispatcher\Default.php(150): Omeka_Job_Dispatcher_Adapter_BackgroundProcess->send('{"className":"D...', Array)
#4 C:\wamp\sanalsunucu\omeka\plugins\DerivativeImages\controllers\IndexController.php(23): Omeka_Job_Dispatcher_Default->sendLongRunning('DerivativeImage...', Array)
#5 C:\wamp\sanalsunucu\omeka\application\libraries\Zend\Controller\Action.php(516): DerivativeImages_IndexController->indexAction()
#6 C:\wamp\sanalsunucu\omeka\application\libraries\Zend\Controller\Dispatcher\Standard.php(308): Zend_Controller_Action->dispatch('indexAction')
#7 C:\wamp\sanalsunucu\omeka\application\libraries\Zend\Controller\Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#8 C:\wamp\sanalsunucu\omeka\application\libraries\Zend\Application\Bootstrap\Bootstrap.php(105): Zend_Controller_Front->dispatch()
#9 C:\wamp\sanalsunucu\omeka\application\libraries\Zend\Application.php(384): Zend_Application_Bootstrap_Bootstrap->run()
#10 C:\wamp\sanalsunucu\omeka\application\libraries\Omeka\Application.php(77): Zend_Application->run()
#11 C:\wamp\sanalsunucu\omeka\admin\index.php(28): Omeka_Application->run()
#12 {main}```

#2

I had similar problems with drivative images for the localhost installation using XAMPP. The ImageMagick need to be at specified version and bit resolution. As my setup was only for some testing, this was sufficient to switch to the GD library for derivatives.

fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_GD"

As for the background processes, you have to setup the correct path to the php executable (BTW the path you’ve written has an error - the two double quote marks are before the path!) . For my XAMPP this is:

background.php.path = "c:\xampp\php\php.exe"

The second option is to set the background process controller to the default synchronous one (if you are not going to perform any long running tasks):

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

#3

As I added “/php.exe” for background.php.path, something happened and finally by derivative images plugin, I get the message

“Processing files. This may take a while. You may continue administering your site.”

… and… it creates nothing new. Same problem continoued.

I also changed, "fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_GD"
and the jobs.dispatcher.longRunning = “Omeka_Job_Dispatcher_Adapter_Synchronous”

but still nothing… after all changes I still get the greenmessage “Processing files. This may take a while. You may continue administering your site.”, but nothing is created. I also checked local folders for any changes.

ps: I checked every image sizes, jpeg,png boxes, all boxes in the derivative image section.


#4

I’ve never used the Derivative Images plugin so I can’t help.

When you apply the above settings and turn off the plugin, does your Omeka create derivative images for the newly added item images?


#5

@miniol
I deactivate the derivative images plugin and then add a new item as you said, but still unable to create derivative images. :frowning: