Database configuration file host

I have been developing an Omeka exhibition locally using MAMP and am now trying to get it working on the web on my university webspace. Unfortunately, in the web installation I have only gotten blank pages or errors. I suspect that I may have the wrong host in db.ini or a socket issue.

Steps so far:
Installed mysql in my directory on student web server
Installed phpMyadmin on student web server
Made a database on student web server with the same name and user with same credentials as on MAMP and imported a backup
Uploaded clean installation of Omeka 2.5 to student web server
Overwrote /files, /plugins, and /themes directories from local site to student web server

At the site root (/omeka/) or the root of any directory, I get the following error:
“Not Found. The requested resource does not exist on this server.”

If I try to navigate to a php file (ex: /omeka/index.php) I get an Omeka page that says “Omeka has encountered an error”. I have followed the codex instructions to view error messages and log errors, but unfortunately they are neither displaying nor logging errors.

If I navigate to /omeka/install/install.php I get a success message, but both links to the public and admin areas give the same “Not Found” error.

In the /omeka/db.ini file I have tried all fields with and without quotations. For the host field I have tried “localhost”, “mysql”, and with no success. At a loss, I also tried the server info in the home areas of phpMyadmin (, but no dice. Here is the info from phpMyadmin:

Database server
Server: via TCP/IP
Server type: MySQL
Server version: 5.5.18 - MySQL Community Server (GPL)
Protocol version: 10
Server charset: UTF-8 Unicode (utf8)

I have also looked into the socket locations and don’t have enough privileges yet to draw any conclusions:

finding socket:
~/mysql/bin/mysql --help | grep “^socket”
socket /da00/d69/jcbeetem/mysql.sock

finding php config file:
php -i | grep ‘Configuration File’
Configuration File (php.ini) Path => /usr/local/apache2/conf (cannot access, even to view file contents)
Loaded Configuration File => /usr/local/lib/php/php.ini (no socket info in this file)

I have a ticket started with the university’s IT department and it has been escalated to an “expert”, but I have not received communication from said expert yet.

Does anyone here have any ideas on what is going wrong?

My first guess is that the .htaccess file that Omeka needs is either not there, or that the server is not set up to use mod_rewrite (or not use the .htaccess file at all). I’d check those first. The server configuration for mod_rewrite is likely something the IT folks will have to check on.

I was able to resolve this mod_rewrite issue by editing the Omeka root .htaccess file and setting RewriteBase to my base directory on the university’s shared web server.

If anyone is setting up Omeka on University of Washington shared web hosting, use these instructions to set up /db.ini and /.htaccess :