CSV import stalled w/ no errors logged

Similar to some previous posts, I’ve having issues with CSV imports stalling while the import is still in the queued stage. This is happening when using both CSV Import and CSV Import+.

  • Omeka Classiv 2.4.1
  • CSV Import 2.0.4
  • CSV Import+ 2.3.3
  • PHP 5.6

Nothing in my configuration or process has changed since my last successful imports via both plugins (that I know of). My log file is empty, as is my php errors file.

I’ve tried following this thread, but I’m not using the CuratescapeJSON plugin, and not sure what else to try.

Any help would be much appreciated, thanks!


That other thread offers an option for getting information about why the job isn’t working: a command that starts with APPLICATION_ENV=development and will print out an error message if the job encounters an error early on. Have you tried that, and if so, was there any output?

Ah, the first couple of times I read through it, it totally went over my head (I can fake my way around the command line but can’t even pretend to know php). When I run either of those, I’m getting:

Could not open input file: application/scripts/background.php.

Googling just turns up tutorials on how to run a script in the background; does this error suggest the plugin is unable to run in the background because it can’t find the file? I’ve checked my server and it seems to have that file in all the right places (if I compare it to the Omeka download package contents…from what I can tell).

Any thoughts? Thanks!

That message probably just means you didn’t run that command from within the top-level directory of your Omeka install.