CSV Import problem

Hi guys, I am using a localhost Omeka installation. The CSV Import plugin is giving me headaches… I have tried the test .csv files which are found in the installation folder of the plugin, but it’s the same. Here’s the stack trace of the error:

exception ‘RuntimeException’ with message ‘The configured PHP path () is invalid.’ in C:\Ampps\www\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php:114
Stack trace:

0 C:\Ampps\www\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php(93): Omeka_Job_Process_Dispatcher::_checkCliPath(’’)
1 C:\Ampps\www\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php(28): Omeka_Job_Process_Dispatcher::getPHPCliPath()
2 C:\Ampps\www\omeka\application\libraries\Omeka\Job\Dispatcher\Adapter\BackgroundProcess.php(31): Omeka_Job_Process_Dispatcher::startProcess(‘Omeka_Job_Proce…’, Object(User), Array)
3 C:\Ampps\www\omeka\application\libraries\Omeka\Job\Dispatcher\Default.php(150): Omeka_Job_Dispatcher_Adapter_BackgroundProcess->send(’{“className”:"C…’, Array)
4 C:\Ampps\www\omeka\plugins\CsvImport\controllers\IndexController.php(386): Omeka_Job_Dispatcher_Default->sendLongRunning(‘CsvImport_Impor…’, Array)
5 C:\Ampps\www\omeka\plugins\CsvImport\controllers\IndexController.php(135): CsvImport_IndexController->_dispatchImportTask(Object(CsvImport_Import), ‘start’)
6 C:\Ampps\www\omeka\application\libraries\Zend\Controller\Action.php(516): CsvImport_IndexController->mapColumnsAction()
7 C:\Ampps\www\omeka\application\libraries\Zend\Controller\Dispatcher\Standard.php(308): Zend_Controller_Action->dispatch(‘mapColumnsActio…’)
8 C:\Ampps\www\omeka\application\libraries\Zend\Controller\Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
9 C:\Ampps\www\omeka\application\libraries\Zend\Application\Bootstrap\Bootstrap.php(105): Zend_Controller_Front->dispatch()
10 C:\Ampps\www\omeka\application\libraries\Zend\Application.php(384): Zend_Application_Bootstrap_Bootstrap->run()
11 C:\Ampps\www\omeka\application\libraries\Omeka\Application.php(79): Zend_Application->run()
12 C:\Ampps\www\omeka\admin\index.php(28): Omeka_Application->run()
13 {main}

That looks like a problem with finding the background PHP path, aka the PHP CLI path. CSVImport and other plugins push their processes out to that, instead of the web interface.

You’ll want to check you server settings for where PHP has its command line interface. Then, in application/config/config.ini, put it in the lines like this:

; If left blank, Omeka will try to autodetect the right path. Set this
; to override the autodetected PHP path.
background.php.path = ""

Thanks for your quick reply.
I’m using an AMPPS distribution, so basically I don’t have an environment variable path set (in Windows).

The config.ini file of the application has the lines you suggested. I have tried to set the path towards the php folder, but

exception ‘RuntimeException’ with message ‘The configured PHP path (C:\Ampps\php) is invalid.’ <-- I tried to set the path manually

Even after I set the PATH for php in Windows system environment variables, Omeka throws the same error:

exception ‘RuntimeException’ with message ‘The configured PHP path () is invalid.’

I’m having the same problem, except that I’m on a shared host (Lunarpages), not Windows.

@tudor, did you find a solution for your problem with the path to PHP-CLI?


@GendoSensei unfortunately, no. I’m using now a different environment, that actually sits on a web server “outside” my localhost… it works there.

Do you have any other app deployed on that host that makes use of PHP (and needs it’s path)?
Maybe asking for support from the Lunarpages team?