CSV Import plus plugin - error with my csv file

Hi there,

I’ve been using CSV Import successfully, but now at the point I need to update metadata not continually create new items, so I want to use CSV Import Plus. I can’t get it to accept my CSV file.

Here is the message I get:

Any help is appreciated.


Hi Victoria,

I try to give informative message in my plugins and modules. In your case, it seems that is file is incorrect. In Csv Import +, a check is done to see if all columns are presents, so there may be a missing one, probably because you modified it manually, or because a “,” in your cells and a missing quote.

The simplest is to use the “Save as” function in your spreadsheet (and save the original before). I don’t have any issues with LibreOffice, but I know that some people have difficulties with Microsoft Office, that doesn’t respect the standards.

You can use too the tabulation as delimiter (it’s very difficult to create a tabulation in a cell of a spreadsheet, so there are never issues).

Thanks, Daniel. I used the tabulation as the delimiter and it worked. The same spreadsheet worked as a CSV file for the non-plus version of CSV Import, which is why I thought something else could possibly be wrong. Thanks for your time, I appreciate it.

This topic was automatically closed after 250 days. New replies are no longer allowed.