CSV Import not working on wamp


I am running Omeka S version 4.0.1 (with PHP 8.2.0 and MySql 8.0.31) and CSV Import 2.4.1 on a local environnement (Wamp 3.3). Every time I try to import a cvs file into Omeka S using CSV Import Module, the job starts, but its status keeps saying “Starting”, and never change that state. I have no error log.

I have set the PHP-CLI path and are not getting the path error (and I get the PHP Cli version from Omeka in System information) but the CSV import module is still not working. I don’t understand what the problem is. Could you please help me to solve it? Thanks

“Starting” forever generally means that the attempt to start the process failed.

One thing you could try is using “synchronous” jobs, which don’t require running a background process. This does mean you can’t do as large or long-running of jobs as a background process would allow, though.

Setting this up requires you to make a change in your config/local.config.php file, inside the service_manager and aliases arrays, add a new line (it can go right under the “Omeka\File\Thumbnailer” line that’s there in the default file:

'Omeka\Job\DispatchStrategy' => 'Omeka\Job\DispatchStrategy\Synchronous',

Thank you very much for your answer, it has worked. :slight_smile:

However I have this two messages on my screen and i don’t know why. Do i have to fix something, somewhere on omeka or on wamp ?
→ Deprecated: auto_detect_line_endings is deprecated in C:\wamp64\www\om4\modules\CSVImport\src\Job\Import.php on line 102
→ Deprecated: Creation of dynamic property CSVImport\Mapping\MediaSourceMapping::$findResourceFromIdentifier is deprecated in C:\wamp64\www\om4\modules\CSVImport\src\Mapping\MediaSourceMapping.php on line 22

Thanks a lot

There’s nothing you have to fix related to those messages.

They’re deprecation warnings related to running the CSV Import module on PHP 8.2. We’ll make the changes to make those not occur in the future.

Thanks a lot for this explanation :+1: