CSV Import no longer pulling in files from URL

Between July 19 2020 and late August, CSV Import began to give me an “Import Error” while processing the first record of my CSV files, each row of which ends with a URL to a .jpg file on my server. All of the file links can be opened in the browser, and I have tried with other valid file URLs.

However, CSV Import just won’t pull the files in from the URLs any more.

I noticed that there has been an update of the CSV Import plugin, and so I have upgraded to version 2.0.5 today. However, I’m getting the same result, I’m afraid. Any ideas?

So when you started getting the problem. you hadn’t updated CSV Import, correct?

Have you turned on error logging to get more information about the error? It’s possible that it’s an issue with your server’s outbound connectivity to the internet, or maybe something totally different.

1 Like

Thanks so much. I turned on error logging and discovered that it is trying to pull files into a directory that no longer exists (/public_html/files/original). I noticed about a month or so ago that the structure of my file system had changed (with an update?). The new directory is /public_html/files/site_images/original/.

The full error message is:

2020-08-31T17:05:46+00:00 ERR (3): [CsvImport][#8] Omeka_Storage_Exception: Destination directory is not writable: '/home/nmrashed/public_html/files/original'. in /home/nmrashed/public_html/application/libraries/Omeka/Storage/Adapter/Filesystem.php:219

Is it Filesystem.php that I need to change? How shall I change the path?

EDIT: No, I hadn’t updated CSV Import when I started getting the problem.

I don’t know what would be going on with this “site_images” folder, that’s not the usual Omeka structure.

Did you install some other plugin or something like that which may have altered that structure? Can you upload files through the web interface successfully?

Basically, Omeka needs files/original (and the other files subfolders) to exist and be writable to be able to upload items. If they’re gone or have improper permissions, that’s something you’ll need to work out.

1 Like

Well, it’s weird then that the file structure is different, but I recreated files/original and moved everything out of files/site_images/original into the proper directory. So far nothing is breaking, and CSV Import works fine now. So, thank you!