CSV import - multivalue separator not working

I’m trying CSV import with a few columns that have terms from multiple custom vocabs. In the CSV file, a cell can contain multiple terms from the same custom vocab, delimited by semi colon. So in the import setting, I have “;” as the multivalue separator, and I’ve set up Batch edit to check the Use multivalue separator. Yet, the results don’t separate the values but show up as “A;B;C” as one line of text. These terms (A, B, C) are entered as custom vocab with ValueSuggest in Omeka.
How can I import these terms as separate terms from cutom vocabs?

The part of the setup we can see here looks correct… maybe you accidentally put some whitespace in the “Multivalue separator” setting box? Or something like that, just because we can’t see that screen of settings in your post.

I’m not aware of any cases where the separator fails to work on the current version of the importer. If you’re sure your settings are correct you could perhaps share a small portion of your input file that fails to work as you’re expecting and we can take a look and/or see if we can reproduce the problem.

Thank you for pointing out the whitespace! I did have unnecessary whitespace in my multivalue separator.
When I was trying to match the separator between the file and the setting, it got mixed up at some point. Now all the terms were imported separately. Thanks!

how can I use <enter> as multivalue separator? Could I use \n in the form ?

You currently can’t use newlines as the multivalue separator.

Ok thank you, I found a workaround.