CSV Import module

I’m trying to load metadata using the new Omeka S CSV Import module. The CSV file is imported but each column is duplicated in every dcterms field. I use tabulation as a delimiter since I didn’t found a way to specify column delimiter like in Omeka Classic plugin.

Metadata columns are labelled using dcterms:title, dcterms:creator, etc.

Which column name must be used for fileURL ou sourceItemId?

These columns doesn’t exist in the standard Csv Import, only in Csv Import Plus. So you have to upgrade Csv Import Plus to Omeka S or, simpler, set multiple urls in the same row than the item.
And the tabulation is not usable, even if very useful, only the standard csv default separator (the comma).

Thank you! Metadata are now imported in separate DC elements.

Anyway, I can’t upload media (files) because “Upload” is not an option for CSV files.

Could you tell me how to specify ingest path to load media?

Digital objects are stored on the Omeka server. For instance: /var/www/Omeka/files/import/PSL/paris001.jpg

For security purpose, local paths are forbidden. That’s the same in Csv Import for Omeka 2 and that’s why Csv Import Plus allows to define a specific local path where assets are. Convert your urls to http://localhost/Omeka/files/import/PSL/paris001.jpg.

The log says that it does not find digital objects:

“Error downloading http://localhost/Omeka/files/import/PSL/paris001.jpg: 404 Not Found”

xxx@omekas:/var/www/Omeka/files/import/PSL$ ls
xxx@omekas:/var/www/Omeka/files/import/PSL$ wget http://localhost/Omeka/files/import/PSL/paris001.jpg
–2017-01-17 11:42:26-- http://localhost/Omeka/files/import/PSL/paris001.jpg
Resolving localhost (localhost)… ::1,
Connecting to localhost (localhost)|::1|:80… connected.
HTTP request sent, awaiting response… 404 Not Found
2017-01-17 11:42:26 ERROR 404: Not Found.

Of course, you should adapt my answer with the true path according to the config of your server (with “/Omeka”?). And/or try another domain like http://univ-psl.fr/.
It should be displayable in your browser if you have access to the server.

Just want to double check that we’re talking about the same thing – the module for Omeka S, not for Omeka Classic.

Right, we’re talking about the Omeka S module. It does work with Daniel’s help.

I can upload files using: wget http://server.com/Omeka/files/import/PSL/paris001.jpg
but not: wget http://localhost/Omeka/files/import/PSL/paris001.jpg

I don’t know why since the path is valid.

Your server could be using name-based virtual hosting to host several sites at once. So, even though “localhost” and “server.com” are the same server, the name you use matters.

Hi Omeka S Team

We have been playing with the CSV import module with great success.

Two of our CSV columns contain hyperlinks-
dcterms:identifer = unique eprint record html link (used Media import option HTML)
dcterms:ispartof = unique eprint collection.html link (used Media import option HTML)

All information is imported into each item, however the HTML link only goes to Omeka S record. To get the live external link we have to go into Edit and manually hyperlink each Item using the hyperlinking feature. Whilst this is a good workaround, we are wondering if there is a step we are missing, it would be great to have the external eprint hyperlink automatically imported with the other CSV template information.

Many thanks


Trying to make sure I get the details…are you looking for the dcterms:isPartOf link to import that item as well? Or is that it is in fact imported because it’s elsewhere in the CSV, but the connection isn’t made within Omeka S? Or something else?

Hello! If I am understanding LibbyS correctly, I believe I am having the same issue. I have also been using the CSV import module for Omeka S.

When I run a CSV import, I would like one of the metadata values to be an external link. However after the import is complete the URL is imported as a text value, not a link or URI value.

During the import process, I make sure to select “Properties” > “Import at URL Reference” in the “Map to Omeka S Data” tab for that specific metadata value.

Currently we have to go in and edit each item’s metadata record manually to change the text value to a URI value. I feel like I might be missing something silly! Any advice/suggestions are appreciated. Thank you!

When you select “Import as Url Reference” are you also selecting the property to which to map?

And which version of the module are you using?

For the most part the columns in my CSV file auto-map to the values in the “Map to Omeka S Data” tab. I also tried deleting the auto-mapped value and manually selecting the property and “Import as URL” and still do not get an imported link.

I am using version 1.0.0-beta2 of Omeka S and version 1.0.0-beta of the CSV import module. I see that a beta2 version has been released recently, so I will try upgrading to that version to see if the new release fixes the issue! Thank you for your help!!

I have more or less the same issue: I would like to import URL as URI.

I tried to select “Import as Url Reference” and a property to map (for instance, source). I also tried to use a resource template where the “source” field is typed as “URI”. The URL is imported as a literal.

I am also using 1.0.0-beta2 of Omeka S and version 1.0.0-beta of the CSV import module.

I haven’t been able to reproduce this with CSV 1.0.0-beta2, so hopefully that’ll do the trick.

If not, am I following right that the URL is imported, but just doesn’t appear as a red link on the admin side? And, what browser are you using?

Right, the URL doesn’t appear as a red link:

I use Chrome 57 and Firefox 52.

To upgrade the module, I also need to update to Omeka S 1.0.0-beta3. I need to do it properly because we’re on production.