CSV Import module not functioning properly, shows [Untitled] and empty data

I am trying to add the content of my csv file as items on omeka s using the CSVImport module, but whenever I click on import after specifying all the settings such as using the base resource template and setting the class as collection, it imports all the data as [Untitled], and doesn’t show any metadata when you expand the item.

Here is what my csv file looks like

Title,Rights,Type,Creator,Date Issued,Description,Language,Link
Test1,rights1,type1,creator1,date1,“description1, this is the description”,language1,https://forum.omeka.org/
Test2,rights2,type2,creator2,date2,“description2, this is the description”,language2,link2
Test3,rights3,type3,creator3,date3,“description3, this is the description”,language3,link3
Test4,rights4,type4,creator4,date4,“description4, this is the description”,language4,link4
Test5,rights5,type5,creator5,date5,“description5, this is the description”,language5,link5
Test6,rights6,type6,creator6,date6,“description6, this is the description”,language6,link6

I tried the omeka s online sandbox and it gave me the same output. Is there anything wrong with the format of the csv file? And what is the correct format I should use?

I am using CSVImport (2.5.0) and Omeka-s (4.0.4)

Could be the double quote in the description in the first data row and the double quote at the start of the language.
Hans Ruedisueli

doesn’t seem like it. I tried it again with a different csv file that looks like this:


and it still showed the same output
[Untitled] for all the titles, and no metadata whatsoever inside the items.

What else could it be?

Hans Ruedisueli

Could you grab screenshots of each step/tab of the import process and post them here? That will help us figure out if any settings are being missed.