CSV Import issues. Jobs stall and remain "in progress" and cannot import users


#1

Hi,

I’ve been running into a lot of issues with my Omeka S install through Reclaim Hosting. Basically, all jobs stall out after a certain number of items although they remain “in progress.” After trying “Attempt Stop,” the jobs also remain in “Stopping.” As well, I am unable to import users through CSV Import and receive a message that “Omeka has encountered an error.” The Easy Install module also does not work. Modules are said to be downloaded, but they are not actually in the filesystem and do not appear under “Modules” as a result. I am able to install modules manually however.

Here’s the longer version of my issues and what I’ve tried so far. Thank you to anyone who can shed some light on this!

  • I initially tried to import my omeka.net site by using the Omeka 2 importer. However, I ran into the issue of batches not completing with stalled jobs.
  • The steps I took involved changing the maximum execution time in INI to 90. I then tried changing it to 0 because this overrides any maximum execution time.
  • I uninstalled and reinstalled Omeka S twice after that. I messed around with the number of items to process per batch and tried running the process with 1 item per batch. This approach did not work.
  • I then decided to import all items through the CSV Import. I encountered the same issue that I did when trying to import from my Omeka.net site. The job continues as “In Progress” even though the job has stopped partially through. Usually it would time out around 140-160 items.
  • I worked around this issue by importing items in batches. I was able to get all of my items onto the site by breaking down my CSVs into several parts each containing no more than 60 items.
  • However, when I went to use CSV Import for user upload, I received a message after mapping elements to fields which stated that “Omeka S has encountered an error.” The job will not start.
  • I cloned my site onto a subdomain and tested out a few different module configurations. I wasn’t able to reach a solution.

The one thing I haven’t tried is installing Omeka S manually instead of through Reclaim Hosting’s installer.


#2

Have you turned on error logging? This might give you some clues to what is causing the jobs to fail.


#3

Thanks, mebrett. I turned on error logging. However, no log was created for the stalled job after I tested out a bulk item import again through CSV Import. So, I don’t have any error messages on why the job stalled.

I tested out a different batch that was just 200 MB . This import worked fine. I’m guessing that file size limitations must be related because the job that keeps stalling is 5GB. All files are already on the server through Sideload.

The bigger and more pressing issue is the user import. Please note that I have replaced my actual domain with DOMAIN for anonymity purposes. I received an error message in both the log and the main header of the page.

From header:

Notice: Undefined index: basic-settings in /home/DOMAIN/public_html/modules/CSVImport/src/Controller/IndexController.php on line 145

Notice: Undefined index: advanced-settings in /home/DOMAIN/public_html/modules/CSVImport/src/Controller/IndexController.php on line 145

Warning: array_merge(): Argument #2 is not an array in /home/DOMAIN/public_html/modules/CSVImport/src/Controller/IndexController.php on line 145

Log:

TypeError: Argument 1 passed to CSVImport\Controller\IndexController::cleanArgs() must be of the type array, null given, called in /home/DOMAIN/public_html/modules/CSVImport/src/Controller/IndexController/public_html/modules/CSVImport/src/Controller/IndexController.php on line 148 and defined in /home/DOMAIN/public_html/modules/CSVImport/src/Controller/IndexController.php:275
Stack trace:
#0 /home/DOMAIN/public_html/modules/CSVImport/src/Controller/IndexController.php(148): CSVImport\Controller\IndexController->cleanArgs(NULL)
#1 /home/DOMAIN/public_html/vendor/zendframework/zend-mvc/src/Controller/AbstractActionController.php(78): CSVImport\Controller\IndexController->mapAction()
#2 /home/DOMAIN/public_html/vendor/zendframework/zend-eventmanager/src/EventManager.php(322): Zend\Mvc\Controller\AbstractActionController->onDispatch(Object(Zend\Mvc\MvcEvent))
#3 /home/DOMAIN/public_html/vendor/zendframework/zend-eventmanager/src/EventManager.php(179): Zend\EventManager\EventManager->triggerListeners(Object(Zend\Mvc\MvcEvent), Object(Closure))
#4 /home/DOMAIN/public_html/vendor/zendframework/zend-mvc/src/Controller/AbstractController.php(106): Zend\EventManager\EventManager->triggerEventUntil(Object(Closure), Object(Zend\Mvc\MvcEvent))
#5 /home/DOMAIN/public_html/vendor/zendframework/zend-mvc/src/DispatchListener.php(138): Zend\Mvc\Controller\AbstractController->dispatch(Object(Zend\Http\PhpEnvironment\Request), Object(Zend\Http\PhpEnvironment\Response))
#6 /home/DOMAIN/public_html/vendor/zendframework/zend-eventmanager/src/EventManager.php(322): Zend\Mvc\DispatchListener->onDispatch(Object(Zend\Mvc\MvcEvent))
#7 /home/DOMAIN/public_html/vendor/zendframework/zend-eventmanager/src/EventManager.php(179): Zend\EventManager\EventManager->triggerListeners(Object(Zend\Mvc\MvcEvent), Object(Closure))
#8 /home/DOMAIN/public_html/vendor/zendframework/zend-mvc/src/Application.php(332): Zend\EventManager\EventManager->triggerEventUntil(Object(Closure), Object(Zend\Mvc\MvcEvent))
#9 /home/DOMAIN/public_html/index.php(21): Zend\Mvc\Application->run()
#10 {main}