CSV Import error


#1

I have tried to upload a CSV file several times and every time I get an error. Therefore, I have edited it manually to make sure it is correct to upload, but I get this:

“Your file is incorrectly formatted. Row beginning with ‘"https: //www.nationalgallery…’ does not have the required 1 rows. Please ensure that the CSV file is formatted correctly and contains the expected number of columns for each row.”

.Let’s say it would be my second row and I do not know where the error is because everything is in order, well formatted. Help?

Thank you!


#2

The first guess with anything CSV-related is the character encoding, so I’d check that it is in UTF-8 encoded. Excel often enough doesn’t do that, so that’s worth a check.

Other than that, could you post up the file itself somewhere so we can take a look at it?


#3

It’s already solved, but thanks also.
But now the problem is that I can’t find that CSV file in my collection. What I can do?

Thank you.


#4

Hmm…sounds like there’s two different things. CSV Import takes the data in the CSV files and uses it to create Items. Once that’s done, Omeka discards the CSV file itself. So, on the other end of the import process, Omeka doesn’t keep the CSV around as an Item or part of a Collection.


#5

Everything is fixed. Thank you very much.