CSRF error: Adding New User

Hello, new Omeka S installation here. Ubuntu 22.04, installed using Git instructions. Able to work through the installation using Readme file. Able to create first user. Able to logout and login again. Able to create a site. But when I try to create a new User, I get a “CSRF: Value is required and can’t be empty” although all four fields have a value.

I have looked through the other CSRF related support requests and do not see anything appropriate for this case. Help appreciated, thank you.

Just to add that I have a fresh installation of PHP 8 also.

This is a very recent regression that’s in the Git development source only. If you pull from Git again you should get the fix for this issue.

Just note: by installing with Git and staying on the default “develop” branch, you’re using our bleeding-edge development code, so sometimes you’ll run into bugs like this.

Thank you. I am inexperienced with git but should have realized I was pulling from an active development branch. The ZIP install was not working for me (Apache settings that I learned about in the README.md) so tried the git install … my mistake. When we install for real we will try again with the ZIP install.

Just to confirm, a git pull has resolved the problem.

Thanks again.

You’ve actually picked a good time to be accidentally on the develop branch: you have the 4.0.0 release candidate code, so it’s quite close (currently exactly the same) as what will be released as 4.0.0 in the near future.

Using Git is a fine option if you’re willing to do the extra setup it requires, though for sites that are “live” I’d suggest checking out a tag so you’re on a specific released version. Also, I can’t think of a scenario where the zip wouldn’t work and the git checkout would, so definitely do try that again later; the zips are there to make the process easier and not require people to use git and npm and composer to get their site running.

Thank you. I ended up running the ZIP install as in v4 when I tried to install modules it was listed as “requires ^3.x.x”

I think my problem was completely unrelated to OmekaS and was an apache2.conf setting for /var/www