Creating custom thumbnails

Hello, new Omeka S user here and here’s my fist question:

I’m having trouble creating thumbnails. It appears thumbnails are selected from the “asset” list and the only way to add an asset is by adding it as a logo to the theme. Then it appears in the asset list and can be selected as a thumbnail. This changes the thumbnail image in the list of items but on the page I’m still stuck with the default video thumbnail.

Can anyone advise if I’m doing it wrong?



You should also be able to add assets from the thumbnail tab when editing an item.

What kind of block or public are you still seeing the default thumbnail?

Ok, I’ll try adding assets from the thumbnail tab when editing an item. I thought I tried that and it wouldn’t add an image as a thumbnail if it wasn 't already an asset.

I don’t know the “kind of block or public” I’m still seeing but here is screen shot of the thumbnail I’m trying to replace.



When you said “This changes the thumbnail image in the list of items but on the page I’m still stuck with the default video thumbnail” - what did you mean by “on the page” - which page?

Thanks for helping.

I’m referring to the “page” or screen that appears when I click on “View Public Site”. I’ve successfully changed the thumbnail in the item list but when I view the public site that item is in, my custom thumbnail is gone.

Can you send a screenshot of what the page you’re building looks like? Specifically the part where the item is, before you click “view public site”

Attached is “Omeka Screen”
This is what appears when I click on “view public image” in sites. The two thumbnails under “Raven” and “Thunderbird 5” are not the thumbnails I chose. I assume they are the default thumbnails for videos.

Also attached is “Omeka Items” showing my list of items with the thumbnails I chose.


Thanks for your time and help.


What does the “edit” page look like for that page? The one which looks like this - that’s where you would select the representative media, if you can.

If you can see what the block is called which contains “Indigenous Canadian computer art” then we can discuss how you might change the representative media for that item, or figure out if this is a bug.

The edit page is attached. “Raven” and “Thunderbird 5” have the default thumbnail rather than the one I chose.

And, I’m using the “Item Showcase” which may be the problem.

I should point out there is only one page in this site so far. I don’t think it is part of a “block”. I thought blocks applied to the contents of pages.

I assume you can’t go into any account you want, even if you work for the “Omeka Team”. I can always add you to the “TAP Team” if you want to get a closer look. I’m all new at this so your help is appreciated.


“Item showcase” is the “page block type” for the part listing the various items.

Knowing which kind of page block you were using allowed me to replicate your issue.

One course of action would be to edit the media itself to change its thumbnail. Go to the admin side view page for the item (Raven), and click on the media in the right-hand drawer on the side. It should look like this:

Clicking on the filmstrip image or the name of the file should take you to the media page. When you edit the media, you’ll have an option to add a custom thumbnail for that media item. Once you’ve done that, it should display properly on the website.

OK, thanks, I’ll try that.

Thanks, I did as you instructed and it worked AOK. Looks great.

1 Like