Copy/Paste from Google Docs to HTML Block Bold Style Issue

Omeka S version 3.1.1 | Chrome |Mac OS 12.3.1

When copying text from a Google Doc into the HTML block on a page, it comes with HTML
<p dir="ltr"><b id="docs-internal-guid-b103975d-7fff-9676-19a0-e47d5703d570">, which makes it bold, but cannot be simply unbolded in the block editor. Users have to click on “source” and delete the extra HTML.

Students are collaborating in Google Docs to draft and edit the text before adding it to the page in Omeka S. A way around this is to click on “source” in the HTML block and paste the text there but it loses any formating (mainly line breaks).

This is not unique to Omeka S (see open issue on another repo, but was wondering if anyone here has any recommendations or if I should open an issue in Github for this. I typically use ctrl/cmd + Shift + v for pasting without formatting, but that doesn’t work in Omeka S.

Thanks so much!

I don’t see the same exact behavior (the text I paste isn’t bold), but I do see the pile of extra markup. We have a plugin loaded in the editor control for handling this type of junk coming from Word, but not for Google Docs. It looks like one is available, so we might have to look at using that too.

For me, using Firefox and Chrome, Ctrl-Shift-V does work and pastes without formatting. At least in Chrome, there should be a workaround if it’s not working: if you hold Control (maybe Command for a Mac, I’m not sure) and right-click in the HTML block, you’ll get the browser’s regular context menu, and in there is a choice to Paste as Plain Text. That should do the same thing as Ctrl-Shift-V though.

Thanks so much for the response. It looks like the Ctrl/Cmd+Shif+V works after I tried again :man_facepalming: I may have rushed in class, but it wasn’t working for me when teaching (as it usually happens).

Thanks for looking into incorporating a Google Docs plugin similar to the Word one.

Yes, the Ctrl/Cmd + right click shows an option to “paste and match style.”

Thanks again!