Can't sort item sets


#1

Hello,

I tried to sort item sets in the results page, for example <site-url>/item-set?page=1&sort_by=dcterms:title&sort_order=asc. But the item sets are not sorted and the ordering remains the same. Could some one investigate that?

Thanks.


#2

Indeed, in public site interface, item sets are sorted by their position before being sorted by sort_by parameter. I don’t know what this site_item_set.position means.

I’ve noted that sorting items in a Browse Preview block doesn’t work too.


#3

The “position” column is recording the site administrator’s selected order of the item sets from the Resources page in the site admin. Unlike items, the tab for selecting item sets also allows an order to be chosen by dragging and dropping.

The interaction between this and the sort selector clearly isn’t working correctly, though.

The Browse Preview thing you mention, @pols12, I think would be a different issue.


#4

I’ve tried to address this issue.


#5

news or solution about this issue?