Can't import files with CSV import plugin

I changed the file link from https:// to http:// and that resolved the issue.

I am a new Omeka Classic 2.7.1 user and cannot successfully import a .jpg or .pdf file with CSV import plugin, but can import metadata if I remove the file column. The file url is to a publicly available website. I select still image as the item type and map dc values, but I am not sure how to map the “file” column. I do check the file box.

Can you help me?

Dump of current csv file data follows:
dcterm:identifier,dcterm:title,dcterm:description,dcterm:source,file
r01a01-02,1850s,“Series 1, Subseries A, Box 1, Folder 2”,Frances Cabaniss Roberts Collection,https://dkdayton.net/uah/roberts2.jpg

1 Like

Can you successfully upload normally?

I have this identical issue. Have confirmed that the URL is public and permanent.

Where should I seek resolution?

Same question: can you upload files normally OK?

Yes. I have just uploaded a file from my local computer.

Also: prior to that upload, I edited the Config.ini and changed Reclaim’s MultiPHP to “ea-PHP72”. Still no joy.

Here is the URL to prove it’s public and permanent: <http://stacks.herculeshistory.org/still_image//Craft_Consulting/Works Acid 1906.jpg>

If you have logging enabled, your Omeka error log should contain information about any errors the import process is running into.

Also, can you share the CSV that’s not working, or a small part of it (even a 1-row version that fails would be helpful)?

(Had hesitated to enable error reporting due to this advice, which was on my training-wheels <omeka.net> site.)

Hi Stephen,

The plugin does not usually provide specific information as to why a CSV failed. If you send us the CSV, though, we’re happy to take a look and see what might be causing the issue.

Best,
The Omeka.net Team

On 8/7/21 2:21 PM, contact-form-noreply@omeka.net wrote:

Name: Stephen Richard Lawton
Email: steve@lawton.net
Site: hercules2.omeka.net
Username: srlawton

Installed & attempting to use CSV Import plugin. Followed all instructions & watched the video.
Import of two items skips both (2) items. Each item has a file URL, which is public and permanent. Format matches those shown in the videos.
I would like to see the error logs. How do I turn on error log display on Omeka.net?

Thank you!

Activating error reporting now.

No joy. Skipped 3 records. No errors displayed.

CSV follows:

**

Dublin Core:Title,Dublin Core:Subject,Dublin Core:Description,Dublin Core:Creator,Dublin Core:Source,Dublin Core:Publisher,Dublin Core:Date,Tag,File,Dublin Core:Contributor,Dublin Core:Rights,Dublin Core:Relation,Dublin Core:Format,Dublin Core:Language,Dublin Core:Type,Dublin Core:Identifier,Dublin Core:Coverage
Point with Acid Plant and Docks - View 1,Acid Plant,Waterfront facilities showing docks in background,HHS,1906,Chemicals,http://stacks.herculeshistory.org/still_image/Craft_Consulting/Works Acid 1906.jpg,
Point with Acid Plant and Docks - View 2,Acid Plant,Waterfront facilities showing docks in background,HHS,1905 early April,“Chemicals, Transportation”,http://stacks.herculeshistory.org/still_image/Craft_Consulting/Works Acid 1905 A.jpg,
Point with Acid Plant,Acid Plant,Waterfront facilities,HHS,1905 early April,“Chemicals, Transportation”,http://stacks.herculeshistory.org/still_image/Craft_Consulting/Works Acid 1905 B.jpg,

Thanks.

The details about what went wrong with a CSV import are logged to the error log, not displayed in the plugin.

Anyway, since you’ve provided a snippet of the CSV, I have a guess: It’s probably the spaces in your URLs causing a problem. Try this URL:

http://stacks.herculeshistory.org/still_image/Craft_Consulting/Works%20Acid%201906.jpg

instead, for that first image. Note the spaces are replaced by %20.

Rookie mistake. My first time back on the command line in 20 years.

Fixed all the blanks in the URLs. Partial success! The resulting item’s file is properly imported, with references to full-size & thumbnails. The URL back to the original has replaced %20 with blanks.

Errors: Imports the first record then skips the final two records.

Also: does not associate the tag with the item. The tag appears on the “Tags” list, but is not associated with the item.

Visually reviewed the CSV and I can’t see anything amiss.

Here is the last four lines in the error log, from two import attempts that each skipped the final two of three records. Looks like it’s calling Omeka, and getting a 404?

142.93.181.240 - - [01/Sep/2021:20:25:37 +0000] “GET /still_image/Craft_Consulting/Works%20Acid%201906.jpg HTTP/1.1” 200 2825548 “-” “Omeka/2.8”
142.93.181.240 - - [01/Sep/2021:20:25:40 +0000] “GET /still_image/Craft_Consulting/Works%20Acid%201905%20A.jpg HTTP/1.1” 404 - “-” “Omeka/2.8”
142.93.181.240 - - [01/Sep/2021:20:25:40 +0000] “GET /still_image/Craft_Consulting/Works%20Acid%201905%20B.jpg HTTP/1.1” 404 - “-” “Omeka/2.8”
3.83.167.191 - - [02/Sep/2021:01:08:20 +0000] “GET /still_image/Craft_Consulting/Works%20Acid%201906.jpg HTTP/1.1” 200 2825548 “-” “Slack-ImgProxy (+https://api.slack.com/robots)”

(The error log modification date has not changed.)

This issue is resolved.

I checked - my filenames were just wrong.

CSV Import operates correctly.