Cannot upload image to item


#1

Hi New to this software for website. This was installed by my predecessor.

We cannot upload image, it produces generic error. I followed the advice given to similar issue and have started log file.

It seems to be an issue with ImageMagick?? Can anyone advise on what to do to allow image uploads?

Thanks

Here is log file:

2018-11-15T12:00:08+00:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file ‘original/4203daeb8c820209cb1e731afcb60a52.jpg’.

2018-11-15T12:00:08+00:00 ERR (3): Omeka_File_Derivative_Exception: ImageMagick is not properly configured: invalid directory given for the ImageMagick command! in /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/File/Derivative/Strategy/ExternalImageMagick.php:82

Stack trace:

#0 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/File/Derivative/Strategy/ExternalImageMagick.php(38): Omeka_File_Derivative_Strategy_ExternalImageMagick->_getConvertPath()

#1 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/File/Derivative/Creator.php(76): Omeka_File_Derivative_Strategy_ExternalImageMagick->createImage(’/tmp/4203daeb8c…’, ‘/tmp/fullsize_4…’, ‘fullsize’, 800, ‘image/jpeg’)

#2 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/File.php(356): Omeka_File_Derivative_Creator->create(’/tmp/4203daeb8c…’, ‘4203daeb8c82020…’, ‘image/jpeg’)

#3 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/Job/FileProcessUpload.php(22): File->createDerivatives()

#4 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Job/Dispatcher/Adapter/Synchronous.php(25): Job_FileProcessUpload->perform()

#5 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Job/Dispatcher/Default.php(137): Omeka_Job_Dispatcher_Adapter_Synchronous->send(’{“className”:"J…’, Array)

#6 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/File.php(203): Omeka_Job_Dispatcher_Default->send(‘Job_FileProcess…’, Array)

#7 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Record/AbstractRecord.php(280): File->afterSave(Array)

#8 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Record/AbstractRecord.php(548): Omeka_Record_AbstractRecord->runCallbacks(‘afterSave’, Array)

#9 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/Item.php(336): Omeka_Record_AbstractRecord->save()

#10 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/Builder/Item.php(203): Item->saveFiles()

#11 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/globals.php(567): Builder_Item->addFiles(‘Upload’, ‘file’, Array)

#12 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/Item.php(321): insert_files_for_item(Object(Item), ‘Upload’, ‘file’, Array)

#13 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/models/Item.php(231): Item->_uploadFiles()

#14 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Record/AbstractRecord.php(280): Item->beforeSave(Array)

#15 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Record/AbstractRecord.php(529): Omeka_Record_AbstractRecord->runCallbacks(‘beforeSave’, Array)

#16 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Omeka/Controller/AbstractActionController.php(229): Omeka_Record_AbstractRecord->save(false)

#17 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/controllers/ItemsController.php(88): Omeka_Controller_AbstractActionController->editAction()

#18 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Zend/Controller/Action.php(516): ItemsController->editAction()

#19 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch(‘editAction’)

#20 /var/www/vhosts/wokingham-tc.gov.uk/httpdocs/museum/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))


#2

Yes, it’s looking for the path where ImageMagick is installed so it can make thumbnails of uploaded images.

If it’s installed you should be able to just put the proper path (i.e., /usr/bin or wherever it’s installed on your server) in the Settings form. There’s also a “Test” button there that should tell you if the path is working.


#3

Thanks.

Our server hosts control this. I have contacted them. They supplied another path to try but that hasn’t worked (test connection doesn’t work). They have now replied

Typically for php stuff you should be using imagick rather than imagemagick

Can you give a try perhaps?

I thought that Imagemagick was ‘built in’ to OMEKA so not sure of this advice or even where to start?


#4

If the server has Imagick support then you can use that instead.

Instructions for configuring Imagick are included in the documentation, basically you just need to add a line to your application/config/config.ini file.