Cache path is not writable - CentralAuth plugin


#1

Good Morning

Hope all is well, sorry if this is in the incorrect section.

I made a Multi instance server with omeka classic instances at the moment i two instance on the server running the following :

  1. Centos 7
  2. Php71
  3. Apache
  4. https://github.com/BGSU-LITS/omeka-plugin-CentralAuth
  • Instance 1 works fine with the CentralAuth plugin and instance 2 does not , everything looks identical been trying everything for the last couple days with no success.

  • Tried version 1.5 and 1.4 of the Plugin

  • Selinux is off

  • tried giving it full access rights

  • When i disable the plugin the server works but not when enabled


tash\Exception\InvalidArgumentException: Cache path is not writable. in /var/www/neurology/plugins/CentralAuth/vendor/tedivm/stash/src/Stash/Utilities.php:229 Stack trace: #0 /var/www/neurology/plugins/CentralAuth/vendor/tedivm/stash/src/Stash/Driver/FileSystem.php(177): Stash\Utilities::checkFileSystemPermissions(’/tmp/simpleCAS_…’, 504) #1 /var/www/neurology/plugins/CentralAuth/vendor/mda515t/simple-cas/src/SimpleCAS/SLOMap.php(26): Stash\Driver\FileSystem->setOptions(Array) #2 /var/www/neurology/plugins/CentralAuth/vendor/mda515t/simple-cas/src/SimpleCAS/Protocol.php(137): SimpleCAS_SLOMap->__construct() #3 /var/www/neurology/plugins/CentralAuth/vendor/mda515t/simple-cas/src/SimpleCAS.php(204): SimpleCAS_Protocol->getSessionMap() #4 /var/www/neurology/plugins/CentralAuth/adapters/CasAdapter.php(58): SimpleCAS->handleSingleLogOut() #5 /var/www/neurology/plugins/CentralAuth/controllers/UsersController.php(267): CentralAuth_CasAdapter->__construct(Array, false) #6 /var/www/neurology/plugins/CentralAuth/controllers/UsersController.php(138): CentralAuth_UsersController->_getAdapter() #7 /var/www/neurology/application/libraries/Zend/Controller/Action.php(516): CentralAuth_UsersController->loginAction() #8 /var/www/neurology/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch(‘loginAction’) #9 /var/www/neurology/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #10 /var/www/neurology/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch() #11 /var/www/neurology/application/libraries/Zend/Application.php(384): Zend_Application_Bootstrap_Bootstrap->run() #12 /var/www/neurology/application/libraries/Omeka/Application.php(73): Zend_Application->run() #13 /var/www/neurology/admin/index.php(28): Omeka_Application->run() #14 {main}

image


  • This error only happens when you go to the login page

Thank you for your help

S


#2

Hello Sarfaraz, I’m the author of the CentralAuth plugin. Sorry for not getting back to you sooner, I only keep up with this forum once a week or so.

It looks like the package that the plugin uses to handle CAS creates temporary files to store session details at /tmp/simpleCAS_map_ followed by a hash. That hash appears to be based on the domain and path from session_get_cookie_params(). If the domain isn’t specified, it uses the SERVER_NAME.

Are your two installations on different domains? If so, I’m guessing that however that is set up is not changing the SERVER_NAME between the two. Otherwise, maybe something is set up oddly with your session settings.

You could also try deleting anything that begins with: /tmp/simpleCAS_map_