Basic search not working (advanced does)

We’ve just migrated an old site from Omeka 1.5.x to 3.0.3 and we’re finding that the basic search route returns no results, e.g.:
http://ulblwebp09.lib.miamioh.edu/picturebook/search?query=dentist&submit_search=Search&query_type=keyword#

but if we use the advanced search, we get the appropriate results:
http://ulblwebp09.lib.miamioh.edu/picturebook/items/browse?search=dentist&advanced[0][joiner]=and&advanced[0][element_id]=&advanced[0][type]=&advanced[0][terms]=&range=&collection=&type=&user=&tags=&public=&featured=&exhibit=&submit_search=Search+for+items

Any idea what we’d need to do to get the basic search to function as expected? (We’re using a non-official Omeka theme, but have confirmed the same problem exists in official themes as well.)

Thanks!

There’s an option in the Search tab under Settings to “reindex.” Have you tried that?

@jflatnes - thanks, that worked once I realized that I needed to specify which fields to index! Thanks for the quick response.

@jflatnes - perhaps I spoke to soon – the basic search works, but the boolean search seems to treat all searches as an OR:
“friend” gets 278 results
“dentist” gets 30
boolean “friend and dentist” gets 305
boolean “friend not dentist” gets 305

ex: https://ulblwebp09.lib.miamioh.edu/picturebook/search?query=friend+and+dentist&submit_search=Search&query_type=boolean&record_types[]=Item

Is there something we need to do in order to activate boolean search availability too?

Thanks

The boolean query mode uses MySQL’s boolean mode which uses + and - before terms rather than and / or.

Great - thanks. Is this be reflected in the documentation somewhere? I was looking at the Search Options section:
https://omeka.org/classic/docs/GettingStarted/Searching/#search-options
which mentions:
" * Boolean, in which you can add Boolean operators like AND and NOT"

Thanks for your help!

Good point. We need to adjust the documentation there.