Avantrelationships - Relationships Editor not displayed in Admin edit


I’m trying to install the AvantRelationships plugin. My problem is that the Relationships editor does not appear when I edit an item, and the quick access Relationships link does not work either.

Omeka Classic - Version 3.1.1
AvantCommon - Version 3.1.0
AvantRelationships - Version 3.1.0
AvantSearch - Version 3.1.0
No other plugin activated
User Profile : Super
PHP: 8.2.7 (apache2handler)
OS: Linux 6.1.0-12-amd64 x86_64
MySQL Server: 10.11.3
MySQL Client: mysqlnd 8.2.7
Apache: Apache/2.4.57 (Debian)

Have you ever encountered the problem?

Thank you for your help!

Hello Dora. Your configuration looks good. Can you provide a little more information and possibly screenshots that show what you are and are not seeing regarding the relationship editor versus what’s described here: Add Relationships to an Item - Digital Archive Docs.

In the Omeka admin back-end, do you see the Relationships item in the left menu?

Best, George

Hi George. Thank you for your quik reply. I can see the Relationships item in the left menu, but if I click an item’s quick access Relationships link I get a 404 error. And there are no Relationships button on the admin Item page. I have attached the screenshots.
Best, Dora

Thanks for the screenshots. I have not seen this problem before, but will try to help you figure it out.

Obviously the plugin is installed, but something is not right. On your screenshot 4, there should be a “Relationships” button below the “Edit” button.

On screenshot 2, what is the URL associated with the Relationships quick link? If you hover over the link, the URL should appear in the lower left corner of the browser or you can right-click the link to get info. It should be something likehttps://your-domain/admin/avant/relationships/12345

Also, how were you able to add a relationship in the first place? Can you perform the same steps again with another item?

This is the URL with the 404 error:

I was unable to add any relationship. The relationship types and rules table in screenshot 1 is like that since the installation. I tried to validate relationships (it said: Checked 0 relationships; 0 invalid relationship(s) found), but still no relationships edit button. There may be a problem on the server side, I will check with our system administrator.

The URL is correct. The only thing I can think of is that AvantRelationships is dependent on another plugin that I was not aware of. It must be AvantAdmin which is not listed in your configuration. Though it might not be a plugin you want activated, you could install it to see if that is what’s causing the problem. I tried deactivating it on one of my sites and the Relationships button disappeared where it should normally appear on your screenshot 4.

Thank you, that solved the problem. I have installed the AvantAdmin plugin and now the Relationships button is there. But as I see in the documentation, this plugin hides the Omeka Collections and Item Type options that I would like to use. Do you think there is a chance to make the AvantRelationships plugin work without the AvantAdmin plugin?

Dora, you can enable the Collections menu item with a simple edit to AvantAdminPlugin.php. On line 23, comment out admin_navigation_main as shown below:

protected $_filters = array(
 //   'admin_navigation_main',

I don’t know if any other changes might be required, but this is an easy one to try. Note that I also updated plugin.ini to set AvantAdmin as a required plugin.

Best, George