Auto thumb generation and derivative images

Hi folks - I know there’s been plenty of discussion about auto generation of thumbnails and images and that’s been really helpful in getting it working kind of - I’m grateful for all the contributions because its really helped. I upload a PDF and it does not generate a thumb but if I run derivative images it does (once I installed ghostscript and updated the ImageMagick policy to read PDF files). I’m running Omeka Classic 3.0.1, PHP 7.3, ImageMagick 6.9, Ghostscript 9.27 on a Debian box. I’d be tremendously grateful if someone could point me somewhere please. Thank you!

Update - I’ve done some more testing and investigation and not sure if this means anything. If I run derivative images with the option"Files that do not have derivative images" it does not update those without a thumb. I have to select the option “All files”

1 Like

Update - well folks I’m at a complete loss now. While I could generate thumbs using Derivative Images even that has stopped working now. I created a test PDF and reprocessed that with and without JPEG 2000 compression, but it made no difference to my problem. I then went to the command line on the box and used ImageMagick’s convert to create a PDF of the PDF. After fixing a policy issue that worked fine. I then used convert again to create a JPG of the front page of the PDF. I did get an error “openjpeg warning: Non conformant codestream TPsot==TNsot.” but a JPG was successfully produced and in fact it was a dam good image too. If anyone can point me somewhere I’d be most grateful. Thank you!

Good news - problem solved - there was an error in config.ini affecting the derivative strategy.