AOI-PMH Harverster and METS


#1

Last week we were testing importing Files + metadata from a Collective Access database into Omeka Classic.

I used to try this already once about two years ago using the OAI-PMH harvester which allowed at the time METS to get the files together with the metadata.

Apparently, this is no longer the case. Instead I read the following on the Plugin page of the OAI-PMH harvester:

“Omeka has plans to translate more metadata formats, such as [MARCXML], [METS], and [RFC 1807]”

The idea we were testing last week was conceived based on the previeous experience we had with Omeka. It took a while before we got there in terms of real-world set-up. So we were really disappointed when we saw that our initial idea wasn’t working any more. For us it was one of the main reason to choose Omeka.

Is there any planning to re-deveolop METS support for this plugin already?


#2

The harvester does support METS in the same way it did 2 (and more) years ago.

That line about “plans” is just an outdated line in the README file… the new addons directory shows that readme contents on the plugin’s page so it’s more prominent and noticeable than it was before.


#3

But it still doesn’t work and we can’t figure out what we would be doing wrong.

Could it be that this particular plugin isn’t compatible with the PHP 7.2 (the version we use)?

METS support is still there, apparently it just doesn’t work with current PHP set ups.

The error is returned with all of the METS feeds we’ve tried, not just the one from Collective Access.

It’s not a CA-specific problem.


#4

What error? I don’t think you mentioned one.


#5

OK other example, because I discovered after googleing the error message that the previous one was uses in 2014 already in some thread about a similar problem.

ID 9
Set Spec 37
Set Name Kaarsenmuseum
Metadata Prefix mets
Base URL https://noorderkempen.whirlihost.com/service.php/OAI/mets
Status Error
Initiated 2018-11-19 09:30:44
Completed [not completed]
Status Messages Error: OaipmhHarvester_Harvest_Mets::_dmdSecToArray(): Node no longer exists (2018-11-19 09:30:53)

This one is a genuine one:

  • There is a set of images + metadata about a local museum (Wax figures) in CA
  • CA has METS/OAI-PMH activated

This is the error message we get in Omeka,


#6

But if I copy paste the call directly into the browser (https://noorderkempen.whirlihost.com/service.php/OAI/mets), I get the following error message from CA:

2018-11-20T07:14:37Zhttps://noorderkempen.whirlihost.com/service.php/OAI/metsNo verb specified.


#7

I’m not certain about the error you’re reporting from the harvester, but the basic problem here is going to be that the METS importer currently in the harvester only supports Dublin Core metadata in METS, where it looks like the repository you’re pointing to uses MODS-in-METS.

To my knowledge, we’ve never had a version of the harvester that supported MODS. It’s just a matter of crosswalking from MODS to Dublin Core and parsing the MODS XML structure, so its far from insurmountable. That being said it’s not in our plans really.


#8

We’ve just spent the last few hours debugging the Omeka METS OAI harvester. The short story is that it’s completely broken in recent versions of PHP. This is possibly due to the fact that the plugin was updated on November 10, 2016.

Is there any chance that this plugin will be updated to work with PHP 7.2 any time soon?

We went that extra mile for our installation and modified the OAI harvester to work with PHP 7.2.

We also modified our mapping as the XML it was expecting was slightly different that what we were producing.

The text fields get mapped and imported now, which is good. The images still don’t show up, but the correct urls are definitely being extracted from the OAI data now.

We still wonder what Omeka is doing with them after the harvester passes them back to Omeka core. Can you help us a bit further to gain more understanding?