Am I able to change the actual NAMES of Dublin Core fields?

I am working on an Omeka website for my school’s anthropology/history/museum studies department. I am currently working on an exhibit/database for Northwest Coast Native American carving, but the site will eventually contain several exhibits/collections. Our multiple collections will feature a wide variety of different item types and we feel that we need to change some of the Dublin Core field names to something that will work universally for our diverse collections. Our concerns are that Dublin Core was designed to work best with historical documents, literature, and artwork, and our collections will often feature physical objects that the some of the existing Dublin Core fields do not fulfill our needs.
Is this possible?
I have searched all features of Omeka and all of the internet, but I can only find legacy forum posts that describe changing code to edit the Dublin Core field names.
Any help would be greatly appreciated!

Is it that you need to change the names of the properties, or would it be sufficient to use some of the DC fields (including title) and create a custom item type which better suits your needs?

We would like to change the names of some of the properties. For example, we want to change
"Title --> Object name" because we are working with a lot of physical objects that do not have “titles”.
I suggested to my professor that we could just create custom element sets for our own custom item types, but the professor either didn’t understand what I meant or there was another issue with doing so.

My understanding is that it’s doable, but requires a fair amount of customization/plugin development. My less-than-ideal workaround was to simply change the display names to map to the terms that made more sense for my collection. That required digging into the PHP files within my theme for the Item show page.

If you need to change only the displayed names of the metadata fields, you can just simply edit your translation *.po file and change all the required names there.

Where can I find the translation *.po files? The files I find end in .mo - I couldn’t open them anyway.

All the .po and .mo files are in the /application/languages directory of your Omeka install.
You need to edit the .po file and compile it to .mo. To do this you can use PoEdit editor.

Nope, there are only .mo-files, in my directory at least. Any ideas on how to access the .po-files if they are not visible in this directory?

All the .po and .mo files should exist in the language directory for the standard Omeka setup. So it looks like you have non standard Omeka installation. What version of Omeka you use and where did you get it from?

I downloaded it at in May and have version 2.6.1, so I think it should be standard.

Ok, now I see that the zip package has no .po files included - AFAIR it used to have them in the past releases.
So you can download required files directly from GitHub (

Oh great, thanks! :slight_smile:

I finally got the file from Github, and tried to open it with Poedit. The program says that the file cannot be opened, because it has errors or is damaged. Do you have any idea why this would happen? Or is there any other way of getting the correct files or another program to edit the file?

Give me the link to the file you downloaded - I’ll try at my computer.

Sounds strange since I’ve just opened the file with no problems.
Try again, downloading the latest Omeka archive ( ), and extracting the desired file from there. It works for me anyhow.

Hey, I just finished working with my translation file and everything works perfectly now. Thank you so much for all your advice and tips!

As for what was said above: am I able to change the names of the fields in the source language (English), too? I can’t find an en_EN file in the translation files directory (which of course makes sense) . I have two parallel sites and the other one is in English, so it would be good to have corresponding terms in use.

Or would it work to edit the Omeka.pot file?

You can also change the default English texts. However the Omeka’s default locale is set to “en_US”. Using the PoEditor just create new translation file from the Omeka.pot template file and save it into the /application/languages/en_US.po file. Now you can modify the desired strings and compile the file.

I’ve tried this exact thing: created the file using poeditor and I’m not seeing the changes in my Omeka site. Is there a way to force it to use the “translations” I’ve put in the file?