After install page looks like something from 1995

I have been fighting with this for a couple of days. I’m in the process of setting up a virtual machine of ubuntu & Omeka for an employee to play with (where she can’t hurt anything). Now I am not new to this as I have setup 2 other instances of Omeka, the one I currently have running is over a TB in size and works great (history.meigslibrary.org). I found that Omeka doesn’t play well with PHP8 and that was cause of most of my issues. So I scrapped that virtual machine and started over. Ubuntu 20.04 with PHP 7.4, & Mysql 8. all “seems” to be working but, when I go to the public or admin pages, what I see looks like 1995 html. Any suggestions will be helpful.
Dan
P.S. running 2.7 of classic

Hi.
What do you mean by “1995 html”? Could you post a screenshot?


Yeah, 1995 html page.
Tried changing the theme to no avail.
Dan

The css stylesheet is not loaded, apparently. Try to find out why.

Wouldn’t want to supply a suggestion? I’m not a webpage guy. I’m a tech support guy (hardware, os, network, etc…)

Okay, after much digging and searching, I started looking into mime types and apache. Turns out there was a setting in apache2.conf that was the issue.

This was the last 2 lines of the file:

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
 SetHandler application/x-httpd-php

I removed SetHandler application/x http-php from the file as it was the only difference between this and a known good installation. reloaded Apache and it works. Being that I am not a code guy, I have no idea what this line did to cause the error but, like I said, as it was the ONLY difference I copied it to a text file just incase then deleted it from Apache2.conf.

I hope this helps anyone else with a similar issue.

I believe the issue here is that line is saying to treat everything as PHP: so your server was trying to execute things like CSS (and possibly even images, etc.) as PHP code. Doing that would definitely cause some problems.

Typically you’d instead see that kind of SetHandler line inside something like a <FilesMatch> section or similar, so it’s only applying to .php files, and really this kind of setting is often provided for you by the configuration files the distribution provides for PHP support in Apache, so you generally don’t need to be providing it on your own.