Advanced Search – change results per page?

How do I change the results per page for advanced search?

I only see the global setting in the main settings for Omeka and the browse ‘results per page’ setting in site admin settings, but they do not affect the number of items shown for advanced search (but only for the simple internal search).

The settings do actually affect the paginator in the sense that if I set them to ‘2’, I may see “1–2 of 3”, but actually all 3 items are shown on the first page and none on the second page.

It looks like the number of items shown is hard-wired to 25 - which is a nuisance especially for the grid view in 3 columns…

I am using Omeka 3.1.1 and Advanced Search 3.3.6.5

1 Like

maybe you can try this way

if you want show 30 items:

Search manager → Page configs → configure(middle icon)
“Default results to display when landing on search page” choice “Results of the query below”
and put per_page=30 in Default query

but paginator must set same count in global setting

Yes, by default, the module uses the site settings or the global settings if not set.

Thank you, this helped and put me on track for a workaround:

Changing the default search in Search manager had no effect.

But setting a “Hidden filter query” per_page=30 on the “Search form (module Search)” on the browse page works

It’s still odd that the paginator must be set separately. But at least in this case it can be done site-specifically through the “Results per page” setting in the “Browse” section of “Site admin”.