Admin login 404, no Apache access

Hi, all! I’m relatively new to Omeka, having used it for a handful of class projects in an already-installed format, so this end of things is new to me. I’ve been trying to install it onto my webspace for the domain I bought through Ionos and just sat on their help line for an hour trying to get the .htaccess file to work to let me install, which it finally did. I was able to get to the install page and fill out admin information, but immediately got redirected to a 404 that reads “/admin/users/login is not a valid URL.”

I don’t have direct access to the server through Apache (as far as I know) because I use a hosting company, which is what most of the solutions I’ve seen on here suggest. I assume it’s an issue with the .htaccess file or mod_rewrite, but for the life of me I can’t figure it out. I have the .htaccess file that Ionos (the hosting company) provided me via customer service that fixed the install problem, but I can’t fix mod_rewrite if that’s the issue. Just trying to work on my thesis and redirect my nervous energy :slight_smile: Thanks in advance.

What did you end up working out to get the .htaccess to work for the install? Did they tell you what they did? There’s a reasonable probability that the error you’re seeing now is an .htaccess problem, too. If you could share a screenshot that would help… my guess would be that the error page has the look of the default public theme, meaning that the .htaccess isn’t directing requests properly to the admin side.

For shared hosting, you usually don’t need access to edit Apache’s configuration: shared hosts generally enable mod_rewrite and respect .htaccess files, which is all that’s required.


Thanks for the quick reply. You’re right, it is showing the default theme with that error message.

This is (most of) the .htaccess file the Ionos support person uploaded that fixed the install issue:

I went to add a picture of the .htaccess file I downloaded from Omeka, but I presume you have access to that, and it won’t let me add more than one picture as a new member.

Needless to say, they’re pretty different files. But honestly, I don’t know enough about the code to tell you meaningfully what changed.

OK, so let’s try something simple.

What happens if you put back the default Omeka .htaccess file? You can keep that changed one around by renaming it to .htaccess.bak or downloading it to your local machine or whatever, but replace the live .htaccess with the one from the Omeka zip and see what that does.

Gave that a shot and it generated the same internal server error I had before. Changed it back and the server error went away, but I got the same 404 on the default theme. Hmph.

Here’s what I just (unsuccessfully tried): I went into the .htaccess file that my hosting provided uploaded and noted exactly what’s different between that and the Omeka zip .htaccess file. Mostly the same concept, except there’s an IfModule tag enclosing some rewrite rules and conditions (IfModule mod_rewrite.c). This screenshot shows exactly where those differences are.

The Omeka file also includes two sections that aren’t in my hosting provider’s file: caching (which is commented, so it has no bearing on the file) and PHP settings (not commented, so maybe an issue, but I’m dubious).

Did they tell you what the “Internal Server Error” was? A redirect loop, some non-recognized line in the .htaccess?

One difference is that they are setting the RewriteBase, so you could uncomment that line in the Omeka .htaccess (remove the # at the beginning of the line). It’s possible that’s significant on this server.

Basically the problem with “their” version is that it is essentially replacing the Omeka rewrite rules, and they don’t have the rule(s) necessary to send admin requests to the admin side.

Just figured out how to make it work after a good bit of tinkering. Here’s what I did: I edited “their” version to remove the section that replaced Omeka rewrite rules, added the missing chunks from the Omeka file, and re-uploaded it. Finally got to the login page.

The RewriteBase thing didn’t work, but it was a good thought. Hoping this doesn’t continue to be an issue, but at least I have a better understanding of what’s problematic if it does. Thank you!

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.