Admin Images won't import any files

I get this error message when I try to upload from my computer, regardless of the type of file I try: File info is incorrectly formatted!

I get this error when I try a url
Unfortunately there was an error importing your image.

I just upgraded to v. 2.8

It looks like there is a compatibility issue with Admin Images specifically and version 2.8.

Thanks for the quick reply - that’s what I was afraid of!

It is not quite the same but I did the line changes above anyway but I hit a problem I did not have with Admin Images before I migrated site and upgraded to 2.8. I try to upload a small .jpg file and hit “File info is incorrectly formatted”, I have tried to un-break this but nothing works,
ADMIN IMAGES ERROR

@Gillespie, I moved your post to this thread instead as it really described a different problem than the one where you first posted it.

That’s fine to move it. Is there a fix for this problem or do I downgrade the whole install of omeka?

I reported it to the plugin’s repository with a possible fix but I’m not sure how active it is anymore.

I believe the “Url” option for adding an image should also still work, so that could be a possible workaround as well.

That did NOT work for me. thanks.

Hi, I am having exactly the same problem as Gillespie. When I try to upload a file with Admin Images, I get the message “File info is incorrectly formatted!”. I am using Omeka 2.8. I would sincerely appreciate any help with this. Thanks in advance!

Had this problem as well! For anyone looking for the solution, I edited the .PHP files for the AdminImages plugin using this Github fix:


and it is now working for me. :slight_smile:

Applied the fix, editing the .PHP files just as weaverfish1 did and it fixed it for me too. Running Omeka 3.0. Thank you!