Admin Images Plugin Installation Error

Hello,

I am attempting to install the plugin Admin Images in Omeka Classic 2.7. As soon as I upload it via SFTP, it causes the entire Omeka site to crash with these error messages:

**Warning** : require_once(/srv/sftp-chroot/classes/lis-462-ol-fa19/omeka-2.7/plugins/AdminImages/helpers/AdminImageFunctions.php): failed to open stream: Permission denied in **/srv/sftp-chroot/classes/lis-462-ol-fa19/omeka-2.7/plugins/AdminImages/AdminImagesPlugin.php** on line **26**

**Fatal error** : require_once(): Failed opening required '/srv/sftp-chroot/classes/lis-462-ol-fa19/omeka-2.7/plugins/AdminImages/helpers/AdminImageFunctions.php' (include_path='/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/application/libraries:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/application/models:.:/usr/share/pear:/usr/share/php:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/plugins/OaiPmhRepository/models:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/plugins/OaiPmhRepository/libraries:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/plugins/SimplePages/models:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/plugins/ExhibitBuilder/models:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/plugins/ExhibitBuilder/libraries:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omeka-2.7/plugins/AccessibilityPlus/libraries:/srv/www/canary.simmons.edu/html/classes/lis-462-ol-fa19/omek in **/srv/sftp-chroot/classes/lis-462-ol-fa19/omeka-2.7/plugins/AdminImages/AdminImagesPlugin.php** on line **26**

I can confirm that the plugin’s folder name is “AdminImages”, and the security permissions are set to rwxrwxr-x, same as the default plugins. Can anyone help? Thank you,

Adriana

Do those same permissions apply inside the folder? If the “helpers” folder is not readable or executable or the AdminImageFunctions.php file is not readable, you’d still get that error.

Thank you John, the problem was with the security permissions within the subfolders. I updated them to match the pattern of the pre-installed plugins and that solved the problem:

Folders - rwxrwxr-x
Files (php, ini, and others) - rw-rw-r