Adding a Header Image to "The Daily" Theme

Hello, I’m just getting started with Omeka, but I’m having trouble adding a header. I’m using “The Daily” theme, and I get this error message every time I try to upload a header image. I have tried different files, different sizes, and different times / days. Do I need to use this feature, or could I just add a header through the CSS editor plugin? Thanks in advance.

Do you only get this error when uploading header images for The Daily, or does it happen with all of the themes in your installation?

It has happened with every theme that I have tried. I have gotten the same message with “Thanks, Roy,” with “Seasons,” and with “Berlin.”

And you aren’t having problems uploading files to items? Only with the header image for themes?

That is correct. I don’t have a ton of items yet, but I have not had any difficulty uploading files for them. Here is a link to my site if you want to see. https://halbaronproject.web.illinois.edu/omeka/

I didn’t realize before since I was only trying to change the header, but I get this message every time I hit “save” on the themes configure page. I can save “navigation” and “settings,” but not “themes.”

Also, I am now using the “Curatescape” theme.

Can you try to enable error logging?

With a “white screen” error like that, you might also find useful information Apache and/or PHP’s server logs.

Thanks. I just tried this and got the exact same error message.

Did you ever figure this out? I am getting the same error message when I try to edit any text in the boxes in the “configure theme” page, which was what was displayed on my “default” home page. I think I will work around by selecting a different “About” page to be my homepage, though this kind of messes up my navigation. I am concerned now, though, that everything on the configure theme page is now permanent, so if I ever need to change the footer text (which addresses licensing etc.), I will have to reconfigure the whole theme.

Thanks for any suggestions!

I talked with the server-side support people at my university, and they updated the PHP from version 7.2 to 7.4 and that fixed the the problem.

Thanks. I’ve been told this is what I have to do, so that makes me hopeful!