Zend Exception on Install

Getting a strange exception in Zend for new install of Omeka S on
Debian 8.10
Php 5.6.33

Used latest zip from Omeka S download link (Jan 10, 2018)
Error header is after setting env to ‘development’ in .htaccess
database.ini checks out - localhost, user credentials for MySQL DB are fine, as are privileges

Omeka S encountered an error
Service with name “Omeka\EntityManager” could not be created. Reason: Redis server went away

No other problems with this server and Omeka Classic, or other MySQL / Php software. I am setting up an omeka dev environment with both S and Classic for handling different client dev needs.
PDO is enabled

I believe the problem here is that the Doctrine code we use is really aggressive about trying to use caching if it’s installed, so I believe it’s noticed that you have the Redis extension, and so assumed that it can connect to a local Redis server.

It’s a problem we need to fix on our end, but if you can remove or disable the Redis extension then this won’t happen.

Not sure exactly how to do that, as unfamiliar with Redis, and its integration.
Found some hints online, but documentation is sketchy.
redis_cache_disable = TRUE
to the subdomain php settings doesn’t fix the issue. Not sure if this properly belongs in the php settings or perhaps nginx, or needs to be in a distinct conf file somewhere else in the Plesk 17.5.3 set up. It does not validate in any conf settings context for php or nginx
Any thoughts? Any indication on when S is going to actually check for a Redis server? or get some handling for this kind of thing? I don’t even know if this VM has Redis; can’t find it in any modules or extensions.

In this case it’d be a PHP extension called redis that you want to disable.

I’m not familiar with Plesk myself but this page from their documentation might be useful.

As for our end of things, we have an issue open to fix this, but I can’t tell you with specificity when that would get done or make it to a release.

Thanks. Yeah, check the extensions in that location. Redis isn’t listed, so not sure where it might be lurking in the php set up. Going to msg my hosting service, and see. Will let you know, since it seems to be calling Redis, but there’s no Redis listed as an extension in the php in the VM. Just weird.

I’ve got the same error, we’re also running Plesk. Did you find a fix for this?

1 Like

We fixed this on our end. That fix will be released in a new Omeka S version (likely 1.1.0), or you could apply it yourself if you need to.

I don’t have a date to give you for the next release right now.


Perfect, copying the entity factory php page into the existing 1.0 version fixed this issue.

1 Like

Fantastic, thanks @jflatnes that worked!