YouTube Importer Error: 'There is no element ..."


I received an error message that says ‘There is no element “Item Type Metadata”, “Player”!

On the advice of another post ( I uninstalled the YouTubeImporter plugin, which solved the problem. However, I would like to actually use the YouTube Importer, which I have previously used without issue! Is there a known way to solve this error if I want to keep the YouTube plugin?

Thanks in advance.

Still struggling with this one. I tried deleting YouTubeImport from the File Manager and reinstalling.

But when I try to look at any of my items (including all the still images), I get this error message: Omeka_Record_Exception: There is no element “Item Type Metadata”, “Player”!

Is there an adjustment I can make that will me to use the YouTubeImport and also be able to view items’s detail pages?


I found the answer on the GitHub page for the plugin.

Here’s what to do:
Go to the Item Types menu (left-hand menu on Admin view)
Add a new Item Type, “Player.”
Add a new element to that the “Player” Item Type, also named “Player”
Save. Reload.
Now you should be able to view items.

This topic was automatically closed after 250 days. New replies are no longer allowed.