Why can't I add more than 150 Items?

Why can’t I add more than 150 Items? I seem to have hit a limit, because now when I add a new Item, it overwrites an old Item to make space.

There isn’t really a practical limit on the number of items, and certainly not one as low as 150.

When you say new items are replacing old ones, what are you seeing happen, exactly?

Thanks for replying, jflatnes!

My Items dashboard says “Browse Items (151 total)”

I click “Add an Item” and am taken to a template with many blank fields. However, some fields have an auto-fill suggestion above them from a previous post, like “Drawer 1, Folder 1.” I don’t want to include this info, or even these fields. I leave the fields blank, but when I click “Add Item,” the fields get auto-filled anyway.

My new Item is called “#155,” but the dashboard still says I have “151 total.” Then I notice that the Item where the auto-filled info was taken from is gone.

Are the ID numbers of the new items continually increasing, or did they seem to “jump backwards” at some point?

The only thing I could think of that would align with this problem is that there’s an incorrect autoincrement set in your database: where it’s supposed to be giving new items new, unused IDs it’s actually reusing old ones. Does this seem like it’s happening?

Also, who’s your hosting provider? I’ve seen something similar to this but I can only remember it happening at one host.

Hi jflatnes,

My hosting provider is Reclaim Hosting. The new Item #s are increasing, even though the total stays at 151. Here are some screenshots of my problem.


UPDATE: I just added 3 new Items, and the total rose to 154. Perhaps there was a limit to how much I could add in 1 day? I still see the auto-fill suggestions, but now their info remains the same. I’d like to turn off auto-fill.

We have seen this problem from a small number of users on Reclaim before.

The issue would eventually “fix” itself on its own as the autoincrement number eventually got high enough to not overlap any previously-used item IDs, so it’s possible that’s what’s happened to you here.

I hope you’re right that the problem may have solved itself. Now how do I stop the auto-fills?

Hi jflatnes, I want to remind you that I’m still seeking an answer for how to turn off the auto-fill suggestions when I post a new Item. Thank you.

I don’t know that I have an answer for you… I personally can’t say that I’ve noticed browsers trying to autofill on the metadata textareas in Omeka before. Maybe this is some browser-specific behavior or configuration?

I don’t think my browser is doing it. I have auto-fill turned off for web browsing, and I never experience it anywhere else. Is it possible that Omeka or an Omeka WordPress plug-in is doing it?

Can you show a screenshot?

There are some plugins that give you dropdowns or suggestions, but you have to enable those on your own. I don’t think any Wordpress plugins would be related.

I sent you these screenshots previously. What else would you like to see?

So by autofill, do you mean the text appearing above the inputs? Or is it text in the inputs? Or both?

What plugins are you using? I’m not aware of any that would cause that text you’re seeing there.

I mean both. The text appearing above the inputs gets auto-filled into the empty space. I’ll take a screenshot of my plug-ins now.

I just added screenshots of my plug-ins to the same link. I have 20 of them. If you can also tell me which ones are unneeded, that would be helpful too.

Omeka itself does/can normally display some text in that area above the inputs: the “comment” for an element.

If you look at Settings -> Element Sets, and click Edit under Dublin Core, you’ll get a list of all the elements in the Dublin Core set, and each one, if you expand it, can have a Comment set here to display on the edit page. Do you have anything filled in to these Comment boxes?

Hi jflatnes, you were right. I edited Dublin Core and found all that auto-fill text in the comment boxes. I just deleted most of it.

Some auto-fills I do find useful. I’d like to know how to manage them. If you look at my screenshots, you’ll see that when I added a new Item only 3 out of the 4 fields were auto-filled. Why is that? Although the auto-fills were always suggested, they were never consistently filled in.

I don’t really have an answer for you on the “auto fill” part of what you’ve reported here: the comments are not supposed to auto-fill into the text boxes, ever.

I just want to be clear on this: you are saying that the text is pre-filled into the boxes on Add, correct? Your screenshots don’t actually show this.

Yes! “The comments are not supposed to auto-fill” yet my screenshots labeled “Add and Item” and “Edit and Item” do show this happening.