Vocabulary import difficulties

I’m getting the same error as in Can’t import new vocabulary, No classes or properties found. Are you sure you used the correct namespace URI?
(Similar error in Can’t import vocabulary (MADS))

  • I’m pulling the Namespace URI from the first line of the file, which is https://onthesegrounds.org/vocab/event-types#
  • I’m uploading a local version of that file, not using the URI of the file
    • Using the vocabulary’s URI throws a different error: Failed to parse statement on line 1
  • File format is set to Autodetect
  • Omeka S version is 2.1.2

Over in that other topic, @jimsafley wrote

For the first of those, it’s possible that the uploaded file is malformed, but in the second, I’m pulling straight from the file; I also tried with the namespace URI that worked with another vocab of the OTG project, https://onthesegrounds.org/vocab#, but that didn’t work for this file.

I don’t know if this validator works properly, but the file does validate as Turtle at http://ttl.summerofcode.be/

Since it’s marked as a SKOS file, I tried http://www.w3.org/2004/02/skos/core# for the namespace URI, but no love there, either.

I think the problem is simply that there are no properties or classes in that file. Everything is a skos:Concept or skos:Collection.

What are you looking to import them as?

1 Like

The Event Types controlled vocab isn’t ready for primetime :slight_smile:

But the rest of the model is.
Namespace: https://onthesegrounds.org/vocab#

1 Like

Another follow-up here:

The OTGEvents Vocabulary is the main vocabulary that includes the properties and classes for making resource templates.

The OTG Event Types vocabulary is a controlled vocabulary, that as John suggested, includes only collections of concepts, so doesn’t have any useful stuff for making templates or items. Though we haven’t done it yet, we’ll serve the contents of that controlled vocabulary as a set of items in an item set so that individual projects using the model can point to those URIs in their Custom Vocab module, once Jim Safley is comfortable merging this branch: https://github.com/omeka-s-modules/CustomVocab/tree/experimental-uri-type That will allow us to fully define and version the terms, without having to spin up a sparql endpoint to serve them.

So, for now, the OTGEvent Types document that you were trying to import is a good reference for the term definitions, but isn’t really functional in the context of Omeka S.

1 Like

Aha! PEBKAC after all. We did get Events imported successfully, and now I have a better sense of what I need to look at in importing vocabularies both for this work and more generally as well.


1 Like

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.