Upgrading from 2.7 to 2.7.1


I created an Omeka site for my library.

I just tried to upgrade to 2.7.1 from 2.7.

I thought that I followed the instructions but when I look at my site it still indicates the 2.7 installation at the bottom of the page. And at the top of the page is says to upgrade to 2.71.

There was one step in the instructions that confused me. Step 6 says to upgrade the database. I am not sure how to do this or even where to go?

I would appreciate any help.


Bill Fischer

If an upgrade is needed, when you go to yoursite/admin, you would be redirected to an upgrade page “If a database upgrade is needed, you’ll automatically be redirected to an upgrade page (example.com/admin/upgrade).”

If you’re still seeing “2.7” and not “2.7.1” in the footers where we list the version numbers, then you went astray somewhere in the process.

You can double-check this too: the file “bootstrap.php” at the top of your Omeka install will list the version number near the top. If it says 2.7 there, then you’re still using the old files (or at least, that one is still old).

Thanks for your responses. I looked at bootstrap.php and it says Omeka verstion 2.7.1. But the footer of the website says 2.7.


So the basic options here are:

  1. The files you’re looking at aren’t the ones that are live on the web (make sure you’re in, I assume, the “localhistory” folder and you’re on the server and all that), or
  2. Your server has some really aggressive PHP file caching enabled, so it didn’t pick up the changes. You probably need to check with your host on this one. Restarting/reloading PHP generally works in these situations.

Thanks for the suggestions. I will check with Dreamhost.




I still have the same issue. I think that I have upgraded to Omeka 2.7.1 but the footer says Omeka 2.7.

I spoke with Dreamhost .

Here is their message:

I see the conversation you posted with
Omeka support and went ahead and tried what they suggested as well as
cleared the caches and made sure the cache was correctly configured, and
then finally restarted PHP as well.

Does anyone have any other suggestions?



So you’re 100% certain that the bootstrap.php file in the live “localhistory” folder of your site says 2.7.1 as the version? Absent the caching ideas I suggested, I don’t know of a way for that to be the case but the version to report as 2.7. I’m left with explanations mostly along the lines of you having more than one copy of the Omeka files on that server, and you upgraded one that’s not the “real” one.

Here is part of the text of the bootstrap.php file

 * Omeka
 * @copyright Copyright 2007-2012 Roy Rosenzweig Center for History and New Media
 * @license http://www.gnu.org/licenses/gpl-3.0.txt GNU GPLv3
 * @package Omeka

// Define the current version of Omeka.
define('OMEKA_VERSION', '2.7.1');

// Define the application environment.
if (!defined('APPLICATION_ENV')) {
    if (!($app_env = getenv('APPLICATION_ENV'))) {
        if (!($app_env = getenv('REDIRECT_APPLICATION_ENV'))) {
            $app_env = 'production';
    define('APPLICATION_ENV', $app_env);

// Define directory path constants.

I am also attaching a screen shot of the directory

I know I am doing something wrong but I cannot figure out what.

Thanks for any help that you all can provide.



Well, this is still pretty much a stumper.

Let’s do a test. It could cause some momentary downtime for your site while you’re doing it, just so you know.

Just delete the bootstrap.php file completely from the server, and then see if there’s any effect. It should immediately cause an error to occur whenever you try to go anywhere within the Omeka site.

You can re-upload the bootstrap.php file after seeing what the effect is.


Sorry for the late reply.

I deleted bootstrap.php and the site continued to work. I then deleted the entire site. And it still worked.

I checked with Dreamhost and their cashing is for 3600 seconds which, if my math is correct, is one hour.

They also said that Omeka might not be compatible with Dreampress.

I want to ask if anyone knows if Omeka works with Dreampress?

The site still does not show upgrade so I do not know what to do.

Thanks for any help.


So, yeah, if you deleted the entire site and it’s still there, this is really something Dreamhost should be able to answer for you. They’re either extremely aggressive in their caching or there’s some confusion about what files are actually being served here: the wrong location, the wrong server, something along those lines. There’s really no alternate explanation for deleting it and having no change. If it is caching they ought to be able to clear/refresh the cache completely.

I’m not sure what Dreampress is so I can’t say much about it one way or the other.


Thanks for all your help.

Another question: would upgrading the Omeka site affect any documents on the site or the structure of the site?


Bill Fischer

Upgrading from 2.7 to 2.7.1 should have no noticeable effects on the contents of your site: it’s just a release that fixes some bugs and makes other little updates like that.

If you’re concerned, we always recommend that you have a backup of your database before upgrading, just in case.

This topic was automatically closed after 250 days. New replies are no longer allowed.