Upgraded; exhibit not loading

Hi! I just upgraded my Omeka installation because it was running an old enough version that I couldn’t install OAI-PMH Repository and I needed to extract the data. The upgrade has been successful and I’ve been able to extract the data, but now nothing loads when I go to the homepage or try to view individual exhibit pages.

There is an index.php in the folder that seems to be the same as in a different, still functioning Omeka installation, and all of the exhibit data in the back end seems to be fine (I also had to hit the upgrade button on Exhibit Builder). It’s just not loading on the front end. What do I need to do?

Thanks!

Can you tell us what versions you upgraded from and to?

@mebrett I don’t remember what it was before (1. something) but it’s now on 2.7.1.

When you say “nothing loads” what exactly are you seeing? A white screen? An error message?

It could just be something simple like you needing to also update the theme you’re using.

I’m seeing a white screen. (If I look at the source, it ends with an open [title] tag.)

It runs Deco, which I thought was updated automatically; what would I need to do to update it?

Sigh, so much ado just to be able to grab the content and run.

So, you can just switch to another theme (in Appearance Settings). The Omeka zip you used to update came with current versions of several themes: as long as you kept those in place you can just use those themes instead (or just go grab the themes out of the zip if you didn’t keep them around when updating).

I’m not sure if Deco itself was ever updated for version 2 and up.

Thanks.

I was able to get to the homepage after switching to another theme, but the exhibit itself still wouldn’t load. Then I updated the theme (Rhythm) and the site is back to not loading at all. Here’s what I see when I view the page source of the homepage:


    <div id="primary">
        
        <p></p>

        <div id="featured-item" class="featured-box">
  

And trying to view an exhibit page:

<!DOCTYPE html>
<html>
<head>
<title>     

Switching it round to a few more themes, I’m now on Seasons, which doesn’t seem to require an update. I can view the homepage now, but still not the exhibit, which ends at an open title tag. What should I do?

Exhibits can use different themes than the main site, so I’d check in the administrative interface for that exhibit to see which theme it is using. You might have to switch there, too.

Oh, thank you! That does appear to have been the (a?) problem. Making sure the two of them match didn’t solve the problem for every theme, but it’s solved it for one of them and hopefully that’s sufficient. (The item images are not loading on the pages, but hopefully this is enough for our archives person to get all the data they need.)

1 Like