Upgrade has killed My Omeka

So because I needed tobe able to switch to reCaptcha v2 for users to be able to contribute, I attempted an upgrade. Every time that I’ve upgraded in the past, despite following the directions, something goes wrong. Same this time.
Contribution was messed up and still getting a recaptcha error. When I tried to change submission settings, I got an error message. No matter what I tried with the guest user, etc to update, I still got the error message. So I decided to reinstall guest user, but that needed record keeper. So I deleted folders and installed the plugins again. Now I can’t even log into my sites admin because I get the error:
These upgrades = death. Does anyone do one without a problem?

Could you post up the stack trace (the list of data underneath the Zend_Acl_Role_Registry_Exception info)? That’ll help us track down what might be wrong. I’m especially curious about the ‘record keeper’ you mention. Is that part of another plugin?

I’m going to retry the upgrade, and I will let you know what happens.
I am not clear on the following. I disable all the plugins. When I do the upgrade. What do I do next. Do I reactive the plugins then? Suppose I am updating a plugin, for example, contribute. Do I still activate it? Or do I delete the Contribute folder from the directory and then copy in the new contribute folder? Or do I not delete the Contribute folder from the plugins folder, but then copy the new Contribute folder right onto the contents of the old Contribute folder. This exact sequence of steps for the plugins has caused confusion for me on previous upgrades. Then I think that I have to activate Guest User befor I do contribute.

Typically when upgrading you want to delete (or move out of the way) the old plugin folder, and replace it with the new one. There’s no need to (and it’s probably a bad idea to) activate it before doing this.

I went back through the entire upgrade process and was able to get everything working. I was even able to get recaptcha v2 to work when I figured out what I had done wrong in getting the keys.
I think that the key thing was just installing the default plugins, and then going back and one by one downloading and installing upgraded versions of my old plugins.
Thanks for your help.