Unable to import to Omeka S via Omeka 2 importer

I’m trying to import the items and collections from an Omeka 2 site into Omeka S. Each time I get the following output in the log file:

2021-11-24T20:22:08+00:00 ERR (3): HTTP problem: 403 Forbidden
Fatal error: Uncaught Error: Call to a member function toString() on bool in /home/dslplatt/collections.dsl-plattsburgh.org/modules/Omeka2Importer/src/Job/Import.php:453
Stack trace:
#0 /home/dslplatt/collections.dsl-plattsburgh.org/modules/Omeka2Importer/src/Job/Import.php(162): Omeka2Importer\Job\Import->hasNextPage(Object(Laminas\Http\Response))
#1 /home/dslplatt/collections.dsl-plattsburgh.org/modules/Omeka2Importer/src/Job/Import.php(91): Omeka2Importer\Job\Import->importCollections(Array)
#2 /home/dslplatt/collections.dsl-plattsburgh.org/application/src/Job/DispatchStrategy/Synchronous.php(34): Omeka2Importer\Job\Import->perform()
#3 /home/dslplatt/collections.dsl-plattsburgh.org/application/src/Job/Dispatcher.php(105): Omeka\Job\DispatchStrategy\Synchronous->send(Object(Omeka\Entity\Job))
#4 /home/dslplatt/collections.dsl-plattsburgh.org/application/data/scripts/perform-job.php(66): Omeka\Job\Dispatcher->send(Object(Omeka\Entity\Job), Object(Omeka\Job\DispatchStrategy\Synchronous))
#5 {main}
thrown
in /home/dslplatt/collections.dsl-plattsburgh.org/modules/Omeka2Importer/src/Job/Import.php on line 453

The source Omeka is at https://plattsburghrocks.org; the destination is at https://collections.dsl-plattsburgh.org.

Any help would be much appreciated!

Did you resolve this? I wasn’t able to reproduce this specific problem.

It looks like there was a 403 Forbidden error… that could be related to server settings on the server you’re importing from… maybe it’s blocking or not serving for the one you’re importing to?

Thanks for the pointer. The project wasn’t time-sensitive so I moved on to other things for a bit. I’ll look at the server settings soon and report back.

I have been trying to import to Omeka-S from Omeka 2. Our original Omeka-S sites was version 3.1.1. I tried importing multiple record sets and only twice did the import complete. The other times, the status remained “in_progress” with typically 300 or 400 items having imported. Most of the sites from which I am importing have more items than that. I tried using the “Per page” setting for the module to limit the number of items imported, but this did not have any effect.

We have a new Omeka-S installation running version 3.2 and now when I use the importer module, the item sets are created correctly but no items are imported. The import status displays as “complete” and I am not seeing any errors.

Any suggestions would be greatly appreciated.

Thanks!