Unable to find / edit apache2.conf file


Trying to install Omeka and am only a couple of steps away from completing the process and have searched every where for an obvious answer. I am following these instructions, although I’m attempting those steps on Ubuntu Server 16.04.

So far it’s been straight forward and everything has worked so far.

The step I’m stuck at is the instructions to activate mod_rewrite, which works, but then running this command: sudo nano /etc/apache2/apache2.conf which is supposed to lead me to a file that look like this:

Directory /var/www/html>

But when I enter in that command, I can see a number of files but not that one.

Does anyone know how I can drill down to that file? Or updated instruction to install on Ubuntu Server 16.04?

Thank you.

When you get to the terminal, try the shorter step of doing /etc/apache2 Then do ls.

Is apache2.conf in the list of files?

That’ll tell us a bit about where the relevant files are located, or not It might just be in a different directory for us to track down.

Are you trying to edit your site file to enable mod_rewrite? If so that is in: /etc/apache2/sites-available

Hello and Happy New Year.

When I try the shorter step all I see in a blank screen with [ New File ] at the bottom (just above the Menu)

When I try apache1 it’s the same message as above.

Thanks for the response and the help.

With regards to whether or not I’m trying to edit my site, I’m not sure.

Just following the linked instructions to try and install Omeka in a test environment.

I tried the /etc/apache2/sites-available but only saw a blank screen with the words “/etc/apache2/sites-available is a direcory” at the bottom of the screen (just about the Menu / Commands)

I installed Omeka on Ubuntu following this: http://omeka.org/codex/Install_on_Ubuntu_using_Terminal

It sounds like you tried to do a ‘nano’ of /etc/apache2/sites-available ?

do a this…

cd /etc/apache2/sites-available

ls -la

You should see something like:

-rw-r–r-- 1 root root 1332 Mar 19 2016 000-default.conf
-rw-r–r-- 1 root root 6338 Apr 5 2016 default-ssl.conf

If you are doing a http site, you would then run:

sudo nano /etc/apache2/sites-available/000-default.conf


sudo a2ensite 000-default.conf
sudo service apache2 restart

then follow the directions from there.