Unable to access Admin Panel


#1

Hi everyone,

We are attempting to use Omeka Classic at our institution but don’t have the IT staff to support troubleshooting server issues beyond simple setup/installation. Right now we have Omeka Classic installed on an iMac running Ubuntu but I’m unable to access the Admin Panel.

These are the messages that I’m getting:

So far I have tried these solutions:

  1. Type sudo nano /etc/apache2/apache2.conf
  2. You should be prompted to type in the password for the user.
  3. After typing in the password the nano program will load the apache2.conf file.
  4. Look for the AllowOverrides setting. It probably says None , so just change it to ​All
  5. Then press CTRL + X , it’ll ask if you want to save, press Y then Enter , and it’ll close
  6. Then restart Apache with the command sudo systemctl restart apache2

That didn’t work. Tried:

  1. Type sudo nano /etc/httpd/httpd.conf
  2. You should be prompted to type in the password for the user.
  3. After typing in the password the nano program will load the apache2.conf file.
  4. Look for the AllowOverrides setting. It probably says None , so just change it to ​All
  5. Then press CTRL + X , it’ll ask if you want to save, press Y then Enter , and it’ll close
  6. Then restart Apache with the command sudo systemctl restart apache2

When I tried to allow overrides in the second location, I was not prompted to log in to a user and get a blank screen instead that says /etc/httpd/httpd.conf doesn’t exist.

What I could try next? Any help would be greatly appreciated!

Thank you,

Blake Jacobsen


#2

Still struggling to access the admin panel. Anyone have any ideas?


#3

It definitely looks like an AllowOverride or mod_rewrite issue. Double-check your AllowOverride line(s), and also run a2enmod rewrite to enable the rewrite module (though the symptoms should look slightly different if that was the only problem).


#4

I figured it out! Thank you. There were several locations that said AllowOverrides and I changed each of them to all and then restarted the server. That seemed to work!