Transferring Omeka site causing Omeka has encountered an error message

I just transferred my Omeka files to my new host and I am now getting the message: Omeka has encountered an error. The most recent error message I’m getting in the file is:

Confirm that the information in your db.ini file is correct.
[14-May-2018 18:25:36 UTC] Omeka fatal error: Access denied for user ‘daisilla_omeka’@‘localhost’ (using password: YES).

I checked and I do have MySQL5 and I created a database in my CPanel, but the only thing it lets me do is name it. I am guessing that my db.ini file info is incorrect, but since I don’t have more details on my MySQL database than its name, I don’t know what to type in.

Maybe my answer is somewhere else in the FAQ, but since I don’t know the lingo, I don’t even know it’s there and apologize for starting a new thread if the answer is somewhere else.

BTW, I was also getting this error message before that repeatedly and I’m not sure whether or not it’s related since the last instance was on 3/18/18:

[18-Mar-2018 08:43:40 America/Denver] PHP Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /home1/daisilla/public_html/omeka/application/libraries/Zend/Validate/Hostname.php on line 549

However, I can’t even find line 549 on that file so I can’t even attempt to fix it.

I would guess that either that MySQL user doesn’t have all the permissions for the database, or there’s a mismatch between the database owner name and what’s listed in Omeka’s db.ini file.

Hi patrickmj,

I wouldn’t be surprised if I don’t have all the permissions to the MySQL database because I only see options to rename or delete it. Do I just get in touch with my hosting service about that?

Also, on the db.ini file, these are the fields:

host = "localhost"
username = "daisilla_omeka"
password = " "
dbname = "daisilla_omeka"
prefix = "omk_"
charset = “utf8”
;port = “”

I don’t see a “database owner name” in any of the fields above, so I don’t know what you mean when you say that the “database owner name” is possibly not matching. The dbname does indeed match the database name. And I left username as is up there but also used the username that I used to use to update my Omeka (item) files , but that didn’t work so I left it as it is above.

Indeed, if you only have permissions to rename or delete, you might very well need to check with your hosting company. You should also have all privileges.

The username field in db.ini should match the owner (user) of the database in MySql, so that’s probably okay, just something to double-check.

The issue was that I didn’t transfer the MySQL database. I only created a shell. So now I transferred it but I’m getting this error message on my current PhPAdmin and don’t know what it means or how to fix it:

SQL query:

– Dumping data for table omk_collections

INSERT INTO omk_collections ( id , name , description , collectors , public , featured , added , modified , owner_id )
VALUES ( 2, ‘Teachable Music’, ‘’, ‘’, 1, 1, ‘2015-12-31 16:39:19’, ‘2015-12-31 16:39:19’, 1 ) ;

MySQL said: Documentation

#1062 - Duplicate entry ‘2’ for key 'PRIMARY

The public message now has this error message:

This page isn’t working is currently unable to handle this request.

That looks like something is trying to add a new collection, but the collection ID already exists, like if you are trying to import the same data more than once, maybe?

Backing out of PHPMyAdmin, does the Omeka site itself seem to work okay?

When you wrote, at least I was getting an Omeka error message on my page, but I must have messed up the files even further because now it looks like this: I don’t even know where to start to try to remedy this situation, which is why I took such a long time to reply…

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.