TImelineJS iframe will not embed

This problem has been referenced several times before: my students and I are finding it impossible to embed a TimelineJS iframe into exhibit pages. Other posts have referenced HTML filtering in security settings; I have tried adding “iframe” to the allowed elements, and just turning HTML filtering off altogether, to no avail. I’ve also tried switching between multiple themes - doesn’t seem to matter.

Here is our unsuccessful public page: http://www.countypoorfarm.butlerhistorical.org/exhibits/show/butler-county-poor-farm-1900-1/butler-poor-farm-timeline

and, if it’s helpful for some reason, the embed code we’ve been trying to use (with beginning and end angle brackets removed so it appears here as text):
iframe width=“600” height=“600” src=“https://cdn.knightlab.com/libs/timeline/latest/embed/?source=1cWqQBZCkX9GpzFtxCWHoqFXCHg-ylTVUWlnrdYMzKUI&font=Bevan-PotanoSans&maptype=toner&width=600&height=600” frameborder=“0”></iframe

Thanks in advance for any suggestions or creative solutions

When I load that page (in both Chrome and Firefox) I get the block for the timeline and it has an error message inside MISSING START DATE. MAKE SURE THE HEADERS OF YOUR GOOGLE SPREADSHEET HAVE NOT BEEN CHANGED. Which indicates that there is a problem with TimelineJS.

1 Like

Thanks so much! Not sure why the error message is not visible when I view it. But now we know where the root problem is…

Interesting that you didn’t see the error. Did you try looking at the page from a browser where you weren’t logged in? (Or a private browser window)