Timeline has no events, how to debug?


I fear this is another case of user error, but I’m at a loss with the SIMILE Timeline, which as the title suggests is not displaying any events, despite (as far as I can tell) being configured correctly. I can get into the specifics of my situation, but is there anywhere I can look for some debugging/sanity checking? Like, can I have it print a list of the events it loaded to see if the problem exists between loading and rendering? Or maybe show me which items were filtered out?

Right now, I don’t see any errors in the interface or the console – just a blank timeline.

Any suggestions are greatly appreciated.


What module are you using for this? Just checking to make sure it gets the attention of the author(s), as it’s not one of ours, I think.

I’m using Timeline by @Daniel_KM . I should probably post an issue on Github if I can’t figure it out, but I thought I’d start here since this is most likely a matter of user error.

OK, I think I figured out the problem. The date field I was using has values as timestamps (e.g. 1562967528) but the Timeline module expects them to already by ISO 8601 strings (e.g. 2019-07-12). I made a duplicate field and it works now.

I’m still not sure how to debug the actual widget, but at least mine works now.

All the data are processed in one file, and output via json : https://github.com/Daniel-KM/Omeka-S-module-Timeline/blob/master/src/Mvc/Controller/Plugin/TimelineData.php .