Thumbnails for PDF files are not being created

I’ve been using Omeka 2.6 without issue since it was released. I had an issue with my server on Saturday and had to restart it, which rarely happens. I tried adding some PDF files to my collection this morning and the thumbnails aren’t being created. Prior to Saturday, this was working. I have tested my Imagemagick path and it says it’s working. Thumbnails for jpg files are being created properly.

Any ideas?

Thank you!

If you have shell access to your server the easiest thing to do is to connect and manually run an identify or convert command on a PDF file and see what happens and what output you get.

I ran:

sudo convert baf0aef99eac7cde5c224e7e9c2439cd.pdf test.pdf

and got this output:

convert.im6: not authorized `baf0aef99eac7cde5c224e7e9c2439cd.pdf’ @ error/constitute.c/ReadImage/454.

convert.im6: no images defined `test.pdf’ @ error/convert.c/ConvertImageCommand/3044.

I was able to fix the problem using the solution from this thread:

but it involves bypassing some security measures, so I will be looking for another more secure fix.