The Geolocation plugin does not display Items on the map

Hello, I have installed the plug-in Geolocation in my site Approximately, up to 50 Items he showed well and I ceased to control it after adding each next Item. However, today I found out that Items on the map are not displayed. At first I thought it was due to Google API Key, I got my own new key, put it in the plugin, but the Items did not appear on the map or in the list to the right of the map.
Tell me, what can it be and what needs to be checked or corrected?
Thank you in advance

Your problem is here:

That file is what underlies the Geolocation map browse page, and if you go there your browser should show you an error about it not being well-formed.

The file appears to have a UTF-8 “byte order mark” character at the beginning, which it shouldn’t. The extra character in all likelihood is written into some file you’re using in Omeka. The Geolocation plugin and the Omeka core shouldn’t have any of those characters, so you’d want to probably focus on any files you’ve edited yourself or plugins from some external source.

A quick way to check if plugins are at fault is to disable all the non-Geolocation plugins you’re using and see if that makes it work. If so you can re-enable them one by one until you find the one that breaks it.

Thank you, I’ll try to deal with it. file must located exactly at this location or inside plugin folder at

It’s not really a “file,” its XML content generated by the Geolocation plugin at that URL. The real file that underlies it is inside the plugin’s folder, but that’s probably not your problem.

This stray character looks like it’s appearing at the start of every page in your site. Most of the time things are loose enough that it doesn’t make a difference but XML is very strict so a stray character at the beginning causes a failure.

It’s quite likely that it’s a plugin or otherwise an edited file to blame, with a plugin the most likely, so I’d start by deactivating everything else other than Geolocation and seeing if that helps.

Thank you. I’ll try to do this, find the edited files. Indeed, I edited them for the purpose of localization and adaptation to the Russian language. And what of the translations of words and expressions that are not in file?

Hi, I just wonder if you have found the root cause of the map markers problem? I have exactly the same issue on my Omeka developer setup and cannot solve it (the same plugin works fine on other setups). I’ve already turned off all the plugins but it didn’t help. I still cannot see item markers on the map and the browser reports map.kml file error.

Just an update: I’ve just found the culprit. It was the Helpers plugin v2.11 ( Turning the plugin off didn’t help but I had to uninstall it to get rid of the problem. I double checked it and if the plugin is installed (and even not active) it makes the Geolocation not to display item markers on the map.

There was a space in the main file of the plugin, it is removed. So the issue is fixed.