The dropdown search menu won't go away

The dropdown search menu on the right side of the screen won’t go away after I added new items to my site today. What’s going on?

Can you share what version of Omeka Classic you’re using, and what version of your theme?

Yes, @jflatnes ! Here is that info. Omeka Classic Version 3.1. Emiglio Theme. I’m not sure how to check the theme version, but the source code shows… “/archive/themes/emiglio/css/style.css?v=3.1”

I’m feeling stuck until I hear back from you. I don’t want to work on my site or share it until we’ve solved the problem.

The way to give us information about your site is to click on “System information” in the bottom right corner, and copy all of the text there and paste it into a comment here.

The problem you’re seeing with the search panel staying open is a known issue with Omeka Classic 3.1. We’re planning to release an update soon that will resolve this problem.

Thank you, I learned that my theme is Emiglio 2.4.2. However, it seems that @jflatnes has figured out the problem.

Thanks for telling me that! Can you say if the update will come in the next week or month or longer, so I can know when to return to working on my site?

The plan is to have it out in the coming days, but I don’t want to pin down a day exactly. I’d be very surprised if it were more than a week from now though.

I will say, you don’t need to stop working on your site in the meantime, either. This issue is a cosmetic problem that the update will resolve, not something that’s changed or worsened by you working on the site.

Omeka Classic 3.1.1 contains the fix for this problem and is now available; you can download it from the usual download page.

Thank you, @jflatnes ! Is this the best way to upgrade? I’m nervous to try because it seems like a lot could go wrong.

Hi @jflatnes , after some trial and error I was able to upgrade to Omeka Classic 3.1.1. So glad to see that the dropdown menu problem was indeed solved! The only thing that looks different to me is the box “Featured Item” on the right side. I think I figured out how to hide that before, but I’m not sure. Do you know how?

In the admin, you can go to Appearance > Configure Theme, and there should be a checkbox for “Display Featured Item”, as well as equivalents for collections and exhibits.

Thanks @kim , that makes sense because I also updated the theme. However, I followed your directions, and I still see that box, saying, “Featured Item: No featured items are available.”

Ah, apparently those settings only affected the homepages and not the browses. I’ve just released Emiglio v2.4.4. with updated settings that include the browse views. Please update again and let me know if that solves the issue for you.

Hi @kim , thank you, that worked to hide the “Featured Item” box! However, I think I’m going to switch back. Too much white space got added above “Browse Items,” and the text column became too wide.

Hi @kim , is it normal that there’s a quotation mark (") above and to the left of the “Featured Item” box?

Ah, seems to be a typo that crept in. I have another fix to include in another release, and I’ll make the correction then.

Hi there. The newest bugfix release for Emiglio, v2.4.5, is now available for download.

Thanks, @kim , it looks great!