Still getting 404 errors messages

I’ve installed Omeka on Ubuntu 16.04 LTS along with the associated packages (MySQL, PHP, PHPMyAdmin, Apache2) by following the instructions listed on the Omeka website. I properly edited my apache2.conf file to enable mod_rewrite and entered in my database settings in db.ini. I was able to successfully install Omeka and get to the main page but I’m getting 404 error messages when I click on any content. Any ideas why?

Thanks in advance!

David

Having everything seem to work but getting 404 on all the pages past the index is almost always an .htaccess problem. Did the installer complain about the .htaccess file or mod_rewrite or anything like that?

I didn’t get an error message during installation.

This is what I have in my .htaccess file:

# Omeka .htaccess: Apache configuration file
# This file is required for Omeka to function correctly.

# --------------- #
# Error Reporting #
# --------------- #

# Uncomment the SetEnv line below to turn on detailed on-screen error
# reporting.
#
# Note: This should only be enabled for development or debugging. Keep this
# line commented for production sites.
# 
# SetEnv APPLICATION_ENV development

# ------------- #
# Rewrite Rules #
# ------------- #

RewriteEngine on

# If you know mod_rewrite is enabled, but you are still getting mod_rewrite
# errors, uncomment the line below and replace "/" with your base directory.
#
# RewriteBase /

# Allow direct access to files (except PHP files)
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule !\.(php[0-9]?|phtml|phps)$ - [C]
RewriteRule .* - [L]

RewriteRule ^install/.*$ install/install.php [L]
RewriteRule ^admin/.*$ admin/index.php [L]
RewriteRule .* index.php

# -------------- #
# Access Control #
# -------------- #

# Block access to all .ini files.
<FilesMatch "\.ini$">
    <IfModule mod_authz_core.c>
        Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Deny from all
    </IfModule>
</FilesMatch>

# --------#
# Caching #
# --------#

# Uncomment the lines below in order to enable caching of some files
# (after a finished site has gone live)
#
# <IfModule mod_expires.c>
#    <FilesMatch "\.(js|ico|gif|jpg|png|css)$">
#        ExpiresActive on
#        ExpiresDefault "access plus 10 day"
#    </FilesMatch>
# </IfModule>

# ------------ #
# PHP Settings #
# ------------ #

<IfModule mod_php5.c>
    php_flag register_globals off
    php_flag magic_quotes_gpc off
</IfModule>

Never mind. I got it working. :slight_smile:
Thanks!

I do a fresh install on Debian and in the config of Apache, you should check if your Directory has the option “AllowOverride All” and not ("AllowOverride None", set by default).

1 Like