Solution for ImageMagick directory path problem when using MAMP (4.2.1) for Macs & Omeka 2.5.1

I’ll cut to the chase and post the solution first, then you can read what follows to see if my situation matches yours.

Problem: the ImageMagick Directory Path setting that automatically installed:
/Applications/MAMP/Library/etc
does not work.

Solution: I contacted MAMP support and they replied:

"I am not familiar with Omeka, or why it is having trouble finding the imagick libraries.
The imagick binaries are here.
Applications/MAMP/Library/bin
The imagick Libraries are here.
Applications/MAMP/Library/lib

So, in Omeka’s General Settings tab I tried replacing “etc” in the Directory Path with “bin”, clicked “Test” and Voila! Omeka replied “The ImageMagick directory path works.” (I also tried replacing “etc” with “lib” and that doesn’t work.)

So, the correct ImageMagick Directory Path is:
/Applications/MAMP/Library/bin

Remember to click “Save Changes” before leaving the Settings page!

Any subsequent uploads will have thumbnails properly created, and they will appear both in the admin pages (the back-end) and the public pages (the front-end). Thumbnails for any previous uploads, however, will not magically appear. I believe you will have to re-upload those files.

Here are the details of my system and situation.
I recently installed Omeka 2.5.1, running locally on my Mac laptop (OS X 10.11.6) using MAMP (4.2.1). After some initial setup problems, I managed to get Omeka running and was able to upload images. But like many other people have experienced, Omeka wasn’t creating thumbnails, and when I started to troubleshoot the issue I discovered that the ImageMagick Directory Path setting was incorrect. During installation, the following was automatically set as the ImageMagick Directory Path:
/Applications/MAMP/Library/etc
In response Omeka returns the error message: "The ImageMagick directory path does not work."
Unfortunately, the previous questions and solutions posted here in the forums about this issue are either several (or many) years old, address MAMP for Windows, or suggest solutions that did not work for me (editing the config.ini file, for example). After searching here and on Google for hours, I finally decided to contact the support team at appsolute (MAMP’s creators). That led to the solution described above.

1 Like