Site not searching certain words

I am using Omeka 2.6 with the Omeka-Bootstrap theme and haven’t updated anything recently.
The site has over 20,000 records, which have all been searchable in the past with no issue. It was reported around a month ago that no search results were being returned for certain words. I have tried re-indexing the records with no luck.

Any advice on what I could check to begin troubleshooting this?
Thanks in advance!

bump for visibility.

Hi @terryit3,

It’s a bit hard to provide help without knowing more about your issue. Which search is failing to find results, is it the built-in Basic or Advanced Search or a plugin such as SolrSearch? What search terms are failing to find results?

@kloor I don’t feel comfortable posting the link to the site publicly, so I will send you the link in a PM. I have tried searching through the admin interface and through the site’s front-end search using the basic search, which doesn’t appear to have an advanced option. I have tried searching using multiple different themes to make sure that wasn’t the issue. I am not using any search plugins.

A quick update to help with some of your questions.

The advanced-search does not work with the Bootstrap theme I was using, so I switched themes and enabled the advanced search option in the theme settings.

If I search the site for ‘library’ as a keyword search, no results are returned. If I search using the Boolean or Exact Phrase option, it appears to work properly.

@terryit3 Based upon the symptoms, it is likely you are running into the limitations of the full-text index that comes with Omeka. See the troubleshooting section of this page, particularly the note that words that appear in more than 50% of the items will not return search results.

Thank you for your help. I am sure that is what’s happening.

Do you know if it is possible to set the default search option to “Exact Phrase” instead of “Keyword” ?

Your theme likely has a setting checked called “Use Advanced Site-wide Search”. If you uncheck that, it will use the Basic Search instead, which will essentially do an Exact Phrase search for Items only.

If you want to continue to use the Advanced Search, the following plugin may work, though I’ve not tried it: