Sections not loading after migration

Dears,
After following-up the migration to a new server guide, I was able to migrate from Omeka Version 2.1.2 to Omeka version 3.0.1, I replaced themes, plugins (and updated the plugins to latest) and files with correct permissions to the webserver and ofcourse the database.
however when browsing sections inside the exhibits the images and text does not load, just empty white sections only the topic of the exhibit can be browsed and the text gets loaded.

I tried to use the debug mode following the procedures hoping to check the errors.log file but nothing is getting written to errors.log file knowing that its enabled from .htaccess and from the config.ini.

Any idea how to troubleshoot on why its not loading?
thanks!

Here is a screenshot from the current production omeka 2.1.2 which shows the Introduction section is loaded with text and picture on the right pane too.
production

Another screenshot shows the Introduction on the latest Omeka 3.0.1 not loaded on the right pane:
omeka-3

2.1.2 is a pretty decent distance from 3.0.1… my first guess would just be that the custom theme needs a small update or two.

You could test that out pretty easily: if you have an up-to-date copy of one of the standard Omeka Classic themes (several are included in the Omeka Classic zip, or you can download one from the themes directory). If the problem is in the custom theme, then switching to a known-good theme would fix the issue.

Another likely sign that it’s a theme issue would be something like the footer not getting displayed either: if there’s an error on the page from a theme problem, then the whole page will stop rendering at that point so things that should appear later like a footer won’t get shown either.

Thank you J!
As I am troubleshooting, I also replaced the updated themes directory from the latest update and seems worked, however I was wondering why no error logs are generated regarding this problem? I cannot see errors on the apache, mysql, omeka level regarding this behaviour.
I will look deep into the theme again.
thanks for pointing out.

If it’s an error then it should generally show with the development mode turned on in .htaccess, and also for most servers an error like that would be logged to the Apache or PHP logs (but usually not Omeka’s own log).

It’s possible that what you have happening though is not an error exactly but just the theme no longer matching up with what Exhibit Builder’s view is expected to be, so it could just be “printing nothing” rather than having an actual error occur.